Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
My daughter 1.6 HDi has had a background whistle on boost for the last 40k and last week she said it buzzing now as well. I dropped the air intake off and sure enough there was now play in the turbo shaft.

I have read how dirty these engines can be so I dropped the sump off, the strainer was clean and the pan was not full of sticky tar like material like I have seen on YouTube videos. The banjo bolt filter looks clean and even the filter in the vacuum pump looks OK.

It really doesn't look that bad at all for a 150k engine so am I missing something or has she just got a turbo that failed due to age and mileage rather than a contaminated oil system?

I plan to change the turbo core, the oil pick up in the sump, the turbo oil supply pipe and banjo bolts, the turbo oil return hose, clean the oil cooler and filter housing and the vacuum pump. Anything else?

Cheers all......
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
That is good news. I don't want to skimp and buy a cheap Chinese core so can anyone recommend a decent place to get a properly manufactured and balanced one? Seen them for £70 on eBay but they must be junk for that price.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
OK well I went with a UK built core from Melett, we did another oil and filter change at 100 miles and we are now over 1000 miles and she is driving lovely.

If anyone is doing this job on a little 207 don't even try to leave the radiator in place. It takes 2 hours to struggle and fail and 30 minutes to lose the rad, just my thoughts.

I think we still have a boost leak because there is definitely a background hiss under boost. One of the sensors on the intercooler pipework still keeps getting oily. I think this is the leak and residue of old oil still in the intercooler coming out with the air. How do I pressurise the intake to check it out?

Also has anyone got an exploded diagram to see if I can get the seals or if I need the whole assembly? The assemble in question connects all 4 of the boost hoses and has about 5 sensors on it.

Thanks...
 

·
Registered
Joined
·
765 Posts
iirc there is always an oil mist in the intercooler / intake, it gets in from the turbo. This is normal. Too much oil would indicate a problem.
 
1 - 5 of 5 Posts
Top