Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Well I have just solved this very common problem on my 2006 1.6 HDi 407 SW

Classic symptoms - Engine light on, centre console tells me Depollution System Fault every time I start the car, goes into limp home mode when I go up a steep hill. (then have to turn off ignition and remove key for a few seconds for it to rev over 3000 RPM again)

Read the codes I get P0100 MAF, P0234 Turbo overboost, P0238 Boost sensor, P1351 and P3008

Reset the codes light goes out but comes back on again the instant I put my foot down.

I purchased a turbo boost solenoid on eBay from Poland £40 OEM from the main factory apparently. Easy to fit just get the car up on ramps its right round the back of the engine at the bottom. two 10mm nuts remove the lower and half undo the upper. Make a note of the 3 hoses before you disconnect them the one on the end is the vacuum supply, the middle one feeds the turbo actuator via an in line filter, the one nearest the connector is a vent pipe. Remove the vacuum pipe at the turbo and check you can suck and blow through this pipe as the in line filter can fail and block the pipe. Do likewise with the vent pipe.

Remove connector and swap units over. Reconnect the pipes and connector and the pipe at the turbo. Start car and check the turbo actuator has fully retracted. Stop car clear codes and hopefully problem solved, mine is all good at the minute.

After a spirited drive all codes still clear apart from P3008 Air flow to high has returned but think I will just leave that one likely its my MAF but car seems to run fine as is.

Hopefully this will help someone, the turbo boost solenoid is a common fault.

cheers Ben
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Maybe slightly premature in my elation.

Depolution warning came back on today after driving 30 miles or so along with engine warning light :-(

On the plus side car is running much better, much better pick up, significantly better fuel economy and doesn't go into limp home mode so all good there.

Suspect my MAF is also dud but don't want to shell out £128 for a new one in case its not that.

Has anyone got a know good one I could try out I am near Stroud Gloucestershire ?

cheers Ben
 
1 - 3 of 3 Posts
Top