Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
hello again guys,

ok so my car has lost all power, now i know the 1.4 hdi isn't anything exciting anyway but at the mo i have total lack of power,

it seems like no turbo boost pressure,

now had a computer on and no faults have shown,

its not blocked piping pre-turbo, and there is no obvious leaks post-turbo. turbo its self seems fine, fully spinning etc. everything with the car works fine, just no power,

i intend on taking cat off tomorrow to see if that may be causing a blockage restricting flow of exhaust.

has anyone else had or seen this problem before, or any other ideas on what i should check before it goes to peugeot for diagnostic... :/

cheers
 

·
Registered
Joined
·
10 Posts
Hello

I had the same problem on my 1.4hdi it was the cat. The inside had turned 90 degres so was blocking the exhaust flow. I just hammered the insides out and put it back together. It has passed the last 2 MOT's like this.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #4
forgot to say i had already unpluged the MAF an no change.

tested exhaust system today and all fine, turbo kicking out plenty of pressure too,

its booked in at peugeot on monday :(
 

·
Registered
Joined
·
71 Posts
Discussion Starter #6
sureley that doesnt prove anything then unplugging it, no power plugged in and no power unplugged

ive been told that if you un plug the MAF it should restore power, (althought the mixture wouldnt be right) - and so would proove the maf is reading incorrectly.
 

·
Registered
Joined
·
9,733 Posts
Try one from a scrap yard then ,

if it was working you should lose power unplugged , if theres no difference plugged in or not then its not working .
 

·
Registered
Joined
·
71 Posts
Discussion Starter #8
i cant loose power by unplugging it, i already have no power at all, so no difference.

the scrappy nearest me never gets 307's in, never mind 1.4hdi :(
 
1 - 10 of 10 Posts
Top