Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hi, I just bought an '03 307 SW 1.4 hdi.

On the way home the engine suddenly died - revs to zero.
Engine would still crank but would not restart.

On calling out the AA they initially could not get the diagnostics to connect and eventually would connect but the ECU would not talk to their system.

They sprayed easy start and it attempted to fire, he checked fuses and discovered the Injector Control Unit Fuse (#4) had blown.

It was replaced, it instantly blew, it was replaced with a 25A fuse and it fired ok. Then a 20A was ok and finally back down to the 15A (as fitted) stayed without blowing.

This got me home - however the underlying problem is still there.
What should I be looking at to fix this properly?

Also the fuel guage doesn't work - but that is a separate issue that was there from day one.

It's still under warranty (for a few more days) and I've reported this to the motor trader I bought it from, so it should be fixed under warranty (bets?).

Any help would be greatly appreciated!
 

·
Registered
Joined
·
1 Posts
Jock07

Hi
I am sure that you will have sorted this but for information.
I had the same problem with my 1.4 hdi 307, I spoke to a Citroen Tech who advised me to disconnect the plug from the bottom of the fuel filter as a fault in this circuit blows the engine control fuse which also controls the heater blower.
I disconnected the plug and fitted a new fuse. Problem solved.
This is well worth a try.
 
1 - 2 of 2 Posts
Top