Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi. I have lurked for the last week or so but had to sign up when I couldn't find an answer that has worked for me.

I recently bought an 03 307 HDI 1.4 but I am having problems. Every morning the car refuses to start. The only way to start it is by bumping it, not even jump leads help when cold. After it has been started and run a little while it tends to start by the key.

I have scoured the forums and found that a common problem is the fuel line under the airbox. There was a hole worn into mine so I ordered it from the main stealer only to be let down. I fixed the problem with heat resistant stretchy tape. I also swapped battery and it will started all day by the key. I think yay!... Fixed it.:thumb:

However, next morning. I flattened the battery trying to start it.:nono:

After getting a push it started instantly, took it for a drive to charge the battery and it started again. I once again removed the airbox etc. to see if my repair had held up; it had and it is dry as a bone under there apart from one injector has a little diesel around the seal at the top.

Next night I disconnected the battery to ensure there was no drain on the battery which may hinder it starting. Next morning it refused again so I had to get a neighbour to push me. It started straight away and restarted off the key after I drove around in it for a while.

There do appear to be bubbles in the fuel line near the primer pump. Obviously not a good sign but it does start by the key with these there when warm and it starts every time when push started. As far as I can tell, it seems like if the starter was stronger it would start. I cannot see why pushing the car starts it when the starter won't 10 seconds later under the same conditions. The starter motor is turning the engine over but it isn't as efficient as bump starting it. I tried to connect to OBD port with my ELM327 and various android apps but it shows nothing stored and so seems to be non-compliant.

So as it stands I am forced to park the car on a hill and hope it starts when I am away from home.

Any tips will be gratefully received.
 

·
Registered
Joined
·
14,602 Posts
Starter could be the issue as ecu needs to see 250rpm to allow starting and if engine is turning a little slow it wont start.

A bad injector will also stop starting as the fuel pressure will be too low but pushing or rolling down a hill turns engine faster and pressure peaks enough to start.

Dirty cam or crank sensor is also possible.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I thought about the starter. Somebody suggested that the starter is not great on the 1.4 and it starts every time when bumped. I would another starter but I cannot find a upgraded version, or maybe mine is on it's way out. I thought it was a case of they either do or don't work.:confused:

As for the crank sensor. Can these be cleaned or is it a replacement?

Thanks for the reply. :thumb:
 

·
Registered
Joined
·
287 Posts
use the torque app to read live sensor readings.

If you can see engine speed and boost pressure etc your bluetooth adapter is working.

I use one on my 04 307 estate 2.0 hdi and it works fine.

There are quite a few bad adapters though that dont work and ones that could possibly damage ECU's. 1.5 versions seem to work fine,

another problem with them aswell on the software side is support for sensors and possibly other access to functions.

its best to use peugot plannet.

If you can see the engine rpm while cranking the engine in your android app that will give you an idea if the starter is turning the engine fast enough.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
@gibbo

Thanks for the links, I'm on my phone which is kinda sporadic on this site for some reason. I rang main Stealer earlier for a price on diagnostics and they wanted 85+vat. I am sure I have seen lexia cheaper on eBay. Maybe it was fake?

It could be worth investing since I am on my 10th Peugeot. Things were much simpler on the 205

@bazsound

My obd reader works well on other cars. Maybe with mine being an 03 there is a protocol problem.

That was a good idea about cranking whilst looking at torque revs widget. Unfortunately It doesn't even show revs.

Somebody else said it was an alternator regulator problem as it is putting 15v into my battery. I am unsure how this would stop it cold starting but allowing it to start off key when warm

I will try and look at the diagnostics map when I get back to my PC. Maybe somebody in Notts has one?

Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
So I finally resolved the problem by fitting a new starter motor. I bought a starter from ebay and only got around to fitting it yesterday. I was worried because for the last week it has seemed like the battery was no longer charging. But seems fine with this starter. Maybe the old starter is seizing up?

Next is the fuel gauge and the speedo.

Cheers all.
 
1 - 7 of 7 Posts
Top