Peugeot Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi I've got a 2007 207, it has no power at all and makes a strange blowing noise, oddly it seems fine when the engine is cold, does the variable timing only work when the engine is warm. I suspect its something to do with the cam timing, i've had the cam cover off and the chain is not loose (I thought it might be the tensioner). I swapped over the cam position sensors hoping the fault would move with it but it didnt. Does anyone have any ideas..?
 

·
Registered
Joined
·
2 Posts
P0014 fault code peugeot 207 1.4 16v

Hi I've got a 2007 207, it has no power at all and makes a strange blowing noise, oddly it seems fine when the engine is cold, does the variable timing only work when the engine is warm. I suspect its something to do with the cam timing, i've had the cam cover off and the chain is not loose (I thought it might be the tensioner). I swapped over the cam position sensors hoping the fault would move with it but it didnt. Does anyone have any ideas..?
Hi, did you manage to find an answer to this issue? Just as I have the same issue on my 2007 207 1.4 16v hunting a little at idle and losing power/blowing noise, sounds like it has an aftermarket air filter on, any help would be grateful. Thanks in advance. Dean
 

·
Registered
Joined
·
4,784 Posts
Hi, did you manage to find an answer to this issue? Just as I have the same issue on my 2007 207 1.4 16v hunting a little at idle and losing power/blowing noise, sounds like it has an aftermarket air filter on, any help would be grateful. Thanks in advance. Dean
does it rattle when starting if so then it sounds like the cam chain
 

·
Registered
Joined
·
2 Posts
Hi, no doesn't rattle, drives superb until warm, then it loses power and sounds as if it has an after market air filter on also has the anti-pollution fault come up....
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top