Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everybody

Recently my friend in all his wisdom decided to lower his car and put a big cone filter. He removed the top of the box cover thing so it is fully exposed.

Anyway into the more pressing matter. We came across a Ford (water over a road not the car) and he hit the Ford at Mach 2 and the car stalled. He then got it started with just a turn of the key. He then went through a second Ford slowly with out problem he then hit the third one at about Mach 1 and the car just stopped again.

We got it going after a simple jump start but it needed jump started everytine to get it going and the wreak from the exhaust and engine bay was shocking.

So he wanted to do some work on it and since then it will not start. The engine will turn over but it is not firing up.
We have completed the following steps

1. Drain the oil from the sump
2. Removed plastic top of the engine and checked for water (it was clear)
3. He removed the injectors, disassembled all the injectors and cleaned the carbon off them etc
4. Replaced the glow plugs
5. Replaced oil and oil filter

And now we're here with a no go Peugeot.

One thing that I have discovered since is that he does not have a fuel pump (I think it's called a lift pump) at the tank. I suggested that air in the diesel line after the filter is possibly causing an issue as you cannot see any movement from the air bubble when trying to turn the engine over. If you push the hand primer it will move along the line and then if you leave it the air bubble comes back along the line towards the diesel filter but he is adamant that that is not part of the issue I may be wrong but giving it a go wouldn't do any harm to remove the air from the line.

The point of this is that the car started before the work and doesn't afterwards. The fuel line was disconnected during the work.

Any suggestions would be great as I think he's on the verge of just setting the car up in flames to use up the half tank of diesel that he has left.

Thanks Daniel
 

·
Registered
Joined
·
1,055 Posts
I think I would check for water ingress into all the connecting plugs and fusebox in the engine bay. If all dry, try tow starting as this is sometimes needed after work on the injectors. Good luck!
 
1 - 2 of 2 Posts
Top