Peugeot Forums banner
electrical circuit system
1-5 of 5 Results
  1. Boxer
    Hi all, I have just repladed the engine on my 2.2hdi 2007 Boxer. I have been plugging the loom back in but found a couple of issues. I can't find a connector on the engine for the yellow connector that goes down the back of the engine at the front end of the engine, can anyone advise me what I...
  2. 508 (2011-18)
    Hello first post from me here hope someone can help me out got the 2011 Peugeot 508. Wipers were working beautifully then after stopping for around 5 minutes I started up the engine and had no control over the wipers. They are stuck on the intermittent speed. I take the keys out and still they...
  3. 206
    Hello everyone, recently I purchased a used 2002 Peugeot 206 and after some time I discovered it had some strange problems. First of all the main problem is that the rear middle brake light is always on but only if the night lights are turned on. One thing I noticed while it is turned on and...
  4. 508 (2011-18)
    Hello there. Bought myself a peugeot 508 1.6 Hdi Emg 2011 model (Allure) two days ago. I live in Norway and this is a scandinavian modell I guess (dont't know if that is any difference). And now the multimedia system has malfunctioned.... It seems like it just goes in a startup loop and the...
  5. 308 (2014-2021)
    I am having so many issues with my car I'm at my whits end. It's a bit of a long story so please bear with me. I purchased it from a dealership in June 2019. It was 3 years old (2016 reg) and had done 25,000 miles. They sold it to me having done a full service. In August I had to have the timing...
1-5 of 5 Results
Top