Steering and Speedo Issues with my van - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 02-09-12, 05:33 AM   #1
Inactive User
 
Join Date: Sep 2012
Posts: 1
Unhappy Steering and Speedo Issues with my van

Hi all, I recently bought a 1999 (T Reg) Peugeot Partner van. At first it seemed okay, but I noticed that the speedo is sticking just over 40mph mark on the dial! It seems to work when I am doing below 40, which is odd. Any ideas?

Also the steering is really heavy, especially when turning slowly! I checked in the handbook to locate the power steering reservoir, but it doesn't seem to have one (well it's not in the place indicated in the handbook!) Stumped! I assume it is electrical or belt driven? It's a struggle for me cos I feel like conan the barbarian by the time I reach my destination, and big muscles don't look good on a girl!

Have also just discovered that the heater/blower, works on the windscreen setting, but when I change the dial to face etc, nothing comes out of the vents and the fan starts to make an almighty racket!

Any help you can give this damsel in distress would be most appreciated.

Got the van booked in for a full service on Tuesday and want to know possible solutions to these problems so I don't get ripped off, as it happens frequently to me at some garages!

Thanks all..x
honehe is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-09-12, 09:32 AM   #2
Inactive User
 
john_h's Avatar
 
Join Date: Nov 2009
Location: Gateshead - Tyne and Wear
Posts: 4,512
Default

in worse case scenerio:

- speedo could need new cluster
- steering could be power steering pump - keep looking for the reservoir, typically hidden low down, has a black cap that twists off.
- blowers will need new flaps installed



john_h is offline   Quick reply to this message
Old 02-09-12, 08:32 PM   #3
davidireland
Guest
 
Posts: n/a
Default

Remove the blower motor and actually have a look at it. The problem should be obvious.
As regards the speedo, it sounds like a clocks problem. Check the gearbox earth also.
The powersteeing problem is most likely the steering knuckle out in the engine bay. They have a tendancy to partially seize. Check the p/s fluid also. There is a reservoir attached to the top of the p/s pump. If it is empty, fill with ATF.
  Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:57 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.