Peugeot expert E7 - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 20-10-08, 09:44 AM   #1
Inactive User
 
Taximan pete's Avatar
 
Join Date: Oct 2008
Posts: 9
Default Peugeot expert E7 power problems.

Hi guys,

I have a peugoet E7 taxi that loses power,

The turbo works but.. The mid range before the turbo comes in is lacking bad.

Its as if the turbo boost comes in too late.

Have changed a few electro valves as they are called but it still plays up.

It has stopped smokling when driving (used to smoke alot) and now smokes on tick over where it never used too.

It has been using silly amounts of fuel ( will need to tow a fuel bowser behind me soon)

Any help or advice will be great.

Last edited by Taximan pete; 20-10-08 at 09:57 AM.
Taximan pete is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 20-10-08, 06:18 PM   #2
 
Join Date: Oct 2008
Posts: 15
Default

sounds like ecu fault try looking for a wire that comes from an injector may be broke but first off i'd get it on a snapon scanner where abouts are you mate
expert.Gavin is offline   Quick reply to this message
Old 20-10-08, 06:21 PM   #3
 
Join Date: Oct 2008
Posts: 15
Default

also i need your year and engine code
expert.Gavin is offline   Quick reply to this message
 
Old 20-10-08, 07:14 PM   #4
Inactive User
 
Taximan pete's Avatar
 
Join Date: Oct 2008
Posts: 9
Default

It is a 55 plate registered on feb 2006. Dont know the engine code.

I have been told it may be the EGR valve or a wastegate problem.

I am lost now.
Taximan pete is offline   Quick reply to this message
Old 20-10-08, 09:54 PM   #5
 
Join Date: Oct 2008
Posts: 15
Default

expert.Gavin is offline   Quick reply to this message
Old 21-10-08, 01:34 PM   #6
Inactive User
 
Taximan pete's Avatar
 
Join Date: Oct 2008
Posts: 9
Default

I have rectified the problem at present.

Mass air flow meter was giving a false reading but showing it was working.

So I changed that at an expense of 115 inc VAT.

And it still now seems to be running ok.

(So it may be an idea if anyone else has this problem and the computer reads a reading to check it with another MAM )

Thanks for all help given .
Taximan pete is offline   Quick reply to this message
Old 16-12-08, 02:22 PM   #7
 
Join Date: Dec 2008
Posts: 5
Default Please help with peugeot expert e7 se

Hi Guys hope everyone is well, I am having nightmares with my peugeot expert e7 se 54 plate, and im losing hope it seems like the never ending story. It has problems with loss of power. Going up hill or up road i can barely pick up any speed it struggles, on motorways its very slow I barely manage 70+ and that too with great effort. The accelerator has to be lightly pressed for power to kick in and after a while it does, pressing fully down does not achieve anything. Occasionaly the engine management light would appear, maybe one a day or soemtimes two days depepnding how much I drive when It does it jerks.

So far I have had the air flow meter changed, tried a few different vaccum valves, and been to a few mechanics. One guy had it diagnosed by launch it read " Intermitent fault injecter one open circuit, battery too low harness resistance ", a few days after driving it wouldnt acelerate in the morning and was contineously jerking, a mate came and touched the injector wiring pushed it in and it was fine. Bu the speed problem is still there, i thought i'd get the injector reconditioned, or change the wiring but before doing so i thought it wud be handy taking it to peugeot. Today the dignostic was carried out, first he said the injector appaered then he cleared it and tested again and it dissappeared other diagnostic guys have done the same it keeps appearing eventually. Peugeot report read " Various intermitent faults in memory , turbo not working correctly, further investigation required to see if turbo is faulty or if a vaccum valve is at fault", I have also changed the turbo sensor. It does drink fuel id say but not awfully bad.

Can soemone please help I wonder if taximan pete had simmilar problems, I just wnat to get this sorted i dont knwo what to do.
Taxi_bob is offline   Quick reply to this message
Old 12-05-11, 10:19 PM   #8
Inactive User
 
Join Date: May 2011
Location: wirral
Posts: 7
Default

Hi Can you get in touch please,

Im currently in the process of dealing with a claim with cab direct and peugeot, i would like to have some help and information to strengthen my case.

Please can you get in touch with on [email protected]
taxidriver29 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:58 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.