Fuel pump/fuel relay advice - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 20-02-12, 04:46 PM   #1
Inactive User
 
Join Date: Apr 2010
Posts: 17
Default Fuel pump/fuel relay advice

Hi

Back with more questions

We have traced my problem with my 03 expert 1.9d down to the fuel pump not pumping fuel to injectors. How do you get to it?? In tank isnt it?

Also we want to try a new fuel relay just in case but which one is it???

Read loads of stuff about its not the pump that goes its the solenoid?? Someone said they cut the brown wire on the black connector and sent a feed from fuseboard to pump. Can anyone give me any information on this so we can get our heads around it. In my black connector i have 3 wires red, green and yellow..... No brown
shelley306 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 20-02-12, 08:37 PM   #2
davidireland
Guest
 
Posts: n/a
Default

No intank pump.
Your problem is most likely with the stop solenoid on the injector pump.
The pump needs to come out as there is a steel cover over the electronics on it.
Have done loads of them, about four hours work in and out.
  Quick reply to this message
Old 20-02-12, 11:29 PM   #3
Senior Member
 
salster's Avatar
 
Join Date: Feb 2012
Location: belfast N.Ireland
Posts: 273
Default

davidirelands right only hdi,s have a low pressure pump in tank
salster is offline   Quick reply to this message
 
Old 21-02-12, 07:31 AM   #4
Inactive User
 
Join Date: Apr 2010
Posts: 17
Default

Noticed some experts did and some didnt. Explains why we cant find a tank hatch in the back of van!! Found a mate who's good on diesels and prepared to help but he has never worked on my vans engine before so trying to save him the investigative work.

SO are we saying that its unlikely to be the pump then? Can i get away with just replacing the solenoid. I know where that pump is at least! So take the pump out, rewire to the new solenoid? Is the solenoid the black plastic disc with three wires coming out of it?? Just so im clear. Heard it all has to be timed back in, but their are cheats to get around it. Like cutting the immobiliser wire. Can someone ellaborate on this please.
On the plus side, all the manifold is already off from when we checked the glow plugs so shouldnt take long

If theres anything else we will need to do that we havnt considered, please let me know. So much easier being able to talk to someone who has already done it. Massive thank you for this. On the plus side, all the manifold is already off from when we checked the glow plugs so shouldnt take long
shelley306 is offline   Quick reply to this message
Old 21-02-12, 07:46 AM   #5
Inactive User
 
Join Date: Apr 2010
Posts: 17
Default

This is the info i have read and would appreciate your comments on.

Yes I had the same problem but because I am a mechanic I fixed the problem myself. You need to remove the cover on the back of the fuel pump this is not an easy job because you need to remove the pump and shear bolts then remove the ecu then put an ignition live to the solenoid and it will work .there will be northing wrong with the pump but please bear in mind this has removed the immobiliser from the van but it save you lots of money. This is a problem Peugeot know about and are unable to test the signal to the ecu


Thanks mark,
I found this was the problem on sunday after checking all the 12v feeds to the pump, instead of dismantling the pump I just cut the brown wire in the black connector and took a fused supply from the fuseboard to the pump... van fired on second turn and so far all is well.
You are right the immobiliser now does not work but what the hell ! this has fixed a problem that defeated four seperate Peugeot dealerships !!! and two motor electicians.

So is this saying i dont need to buy a new solenoid. Dont understand the bit about cutting the wire? Where would i connect the live ignition feed to?

Sorry to be a pain with all these questions. Always a pain when you have never done one before. Thanks
shelley306 is offline   Quick reply to this message
Old 21-02-12, 10:39 AM   #6
Inactive User
 
Join Date: Apr 2010
Posts: 17
Default

Hmmmmm How do i get the metal bracket off??
shelley306 is offline   Quick reply to this message
Old 21-02-12, 05:43 PM   #7
jmkent
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by salster View Post
davidirelands right only hdi,s have a low pressure pump in tank
Correction.... no they don't.... only some HDIs have pumps in the tank, namely the older and smaller engine ones
  Quick reply to this message
Old 21-02-12, 08:04 PM   #8
Inactive User
 
Join Date: Apr 2010
Posts: 17
Default

Anyone able to give me some guidance on this?? I have been told..... Underneath the throttle sensor is a metal bracket. Apparently under this bracket i will find the stop solenoid and the pump. Iv been told there is an immobiliser on side of the pump?

What is best to do first as far as "common issues" go. Need to sort this as cheap as possible hence doing job ourselves.

Can anyone give me tips or tell me anything that i am likely to have an issue with, things i need to know.

Its now getting desperate as i need to have this vehicle back on the road asap.
shelley306 is offline   Quick reply to this message
Old 21-02-12, 08:52 PM   #9
davidireland
Guest
 
Posts: n/a
Default

Timing belt off, pump off, steel cover off, electronics off. Your're left with a stop solenoid. Wire a 12v ignition supply from the square black connector that used to be connected to the electronics to the top of the stop solenoid. Pin 1 i think, but check to be sure.

This job should be very basic to a decent mechanic!
  Quick reply to this message
Old 21-02-12, 09:01 PM   #10
Inactive User
 
Join Date: Apr 2010
Posts: 17
Default

Thanks so much for that.

To be honest my mechanic friend hasnt had a proper look at it as yet. He diagnosed the problem being fuel pump area then had to rush off. He's coming tomorrow hopefully. Just nice to know the ins and outs. He has said he hasnt worked on one of these before.

Iv been told that the bracket is hell to get off. Any tips on that score??
shelley306 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 03:11 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.