Expert HDI won't start. - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 09-02-16, 07:20 PM   #1
Inactive User
 
Join Date: Feb 2016
Posts: 11
Default Expert HDI won't start.

My van wouldn't start a few days ago, RAC sprayed easy start and it sprang into life.
when driving - it then cut out momentarily several times as if the ignition had been switched off.

Next time I tried to start it - it wouldn't. easy start doesn't work now.

The temperature gauge swings full scale three times when the ignition is turned on. (it doesn't do this normally)
The code reader I borrowed says it cannot connect to the ECU.
I tried another key.
The immobilizer light goes out.

Any ideas gratefully received.
campervanman is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-02-16, 08:02 PM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,926
Default

If t wont start on easy start you have a mechanical issue a code reader wont really help other than to confirm this.

First you need to tell us WHAT engine we are talking about as there is a fair choice considering you dont even say what age it is at least 6 possibilities
__________________
assume nothing check everything twice !!
reliable406 is offline   Quick reply to this message
Old 09-02-16, 08:45 PM   #3
Inactive User
 
Join Date: Feb 2016
Posts: 11
Default

its a peugeot expert 2006 2.0 HDi. Bosch ECU FHZ

It will ignite the easy-start but will not continue to run.

I noticed the first time it failed to start - If I turn on the ignition and the temperature guage does the three sweeps from MIN to MAX it wont start.
If the guage stayed at MIN it would start.
Currently the code reader cannot communicate.
campervanman is offline   Quick reply to this message
 
Old 09-02-16, 09:20 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,926
Default

You must mean RHZ ok its an early model 8 valve engine code reader cannot read a locked ecu the most likely thing is wiring issues going by your initial post

Check the loom where it goes into the ecu it rubs on the inner wing there and can short out also check the stop switch nearby on strut tower

When you turn on the ignition you should hear the tank pump do you ?

There is a power relay on passenger inner wing roughly same place as ecu on drivers side.
__________________
assume nothing check everything twice !!
reliable406 is offline   Quick reply to this message
Old 09-02-16, 10:11 PM   #5
Inactive User
 
Join Date: Feb 2016
Posts: 11
Default

no tank pump noise, I did check pump fuse just in case,
I reseated the power relay connector and unbolted the ECU and reseated the cable connectors, But will look for more cable issues Thursday - and the stop switch. (the van is stuck at the office)

Thanks
campervanman is offline   Quick reply to this message
Old 14-02-16, 12:00 PM   #6
Inactive User
 
Join Date: Feb 2016
Posts: 11
Default half working

Its not raining today so had a look for broken wires at the ECU end and above the alternator.
Then checked the dual relay.

If I bypass the relay by linking pins 8 - 4 and 11 - 1, on the socket, the van will start. The relays click if power is connected across the coils.

There is no earth supplied on pins 10 or 7 to operate the coils in normal use.

where is the best place to get a copy of the wiring diagram? - found something now..looks like it covers the area... 7 should be ground and 10 goes via the stop switch to ground.

cheers

Last edited by campervanman; 14-02-16 at 12:07 PM. Reason: update
campervanman is offline   Quick reply to this message
Old 14-02-16, 12:23 PM   #7
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,775
Default

Key in ignition with drivers door open does it beep
__________________
Great deals on car keys contact me 07599587119
trustme is offline   Quick reply to this message
Old 14-02-16, 12:49 PM   #8
Inactive User
 
Join Date: Feb 2016
Posts: 11
Default beep?

hi...
do you mean like the lights on beep?
no it doesn't.. with our without the relay bypassed..
is this a clue..?
thanks
campervanman is offline   Quick reply to this message
Old 14-02-16, 01:41 PM   #9
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,926
Default

Ignore that these vans dont always beep !!

Different immobiliser system on these and the beep gets broke

If the red immobiliser light goes out thats fine sounds like a power fault as the relay you are shorting also powers the tank pump the relay is fed from a main fuse nearby which comes from battery it is powered up by ignition switch i would concentrate on the wiring near the relay
__________________
assume nothing check everything twice !!

Last edited by reliable406; 14-02-16 at 01:44 PM.
reliable406 is offline   Quick reply to this message
Old 14-02-16, 06:35 PM   #10
Inactive User
 
Join Date: Feb 2016
Posts: 11
Default

took advantage of it running in bypass to do those tasks not possible by bike or bus.... on Tuesday I'll continue looking for the actual fault.
campervanman is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:13 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.