Black smoke - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 22-06-16, 08:40 PM   #1
Senior Member
 
Join Date: Apr 2014
Location: Lanark
Posts: 143
Default Black smoke

2008 E7 taxi 2.0 HDI 16V, As above, since taking out the egr blanking plate and fitting good replacement EGR valve, when hard accelerating in 2nd and 3rd gear I get a blast of black smoke, seems to be just as the turbo kicks in around 1700rpm. It used to do this before I blanked it off so it's not new. Anyone suggest if this is normal or what causes this. there's plenty power and the engine only uses about 1/2 ltr oil a month which is about 1500mls and fuel consumption is 32mpg stop start driving in city.

Last edited by E7 58reg; 22-06-16 at 08:42 PM.
E7 58reg is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 26-06-16, 07:58 PM   #2
Senior Member
 
Join Date: Apr 2014
Location: Lanark
Posts: 143
Default

Under hard acceleration in 3rd gear last night, cab lurched and then EML came on and anti pollution fault on screen, engine recovered and still drove ok. Plugged in code reader and said excessive turbo boost. 1st time this has happened, could this be related to the black smoke thing above.. and what could cause excessive turbo boost....anybody???
E7 58reg is offline   Quick reply to this message
Old 26-06-16, 09:15 PM   #3
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,775
Default

Quote:
Originally Posted by E7 58reg View Post
Under hard acceleration in 3rd gear last night, cab lurched and then EML came on and anti pollution fault on screen, engine recovered and still drove ok. Plugged in code reader and said excessive turbo boost. 1st time this has happened, could this be related to the black smoke thing above.. and what could cause excessive turbo boost....anybody???
Try put a new air filter in and see what happens
__________________
Great deals on car keys contact me 07599587119
trustme is offline   Quick reply to this message
 
Old 27-06-16, 09:40 AM   #4
Senior Member
 
Join Date: Apr 2014
Location: Lanark
Posts: 143
Default

New filter fitted, old one was choked with muck and leaves. Was only changed about 5000 miles ago but just shows you
E7 58reg is offline   Quick reply to this message
Old 29-06-16, 08:56 AM   #5
Senior Member
 
Join Date: Apr 2014
Location: Lanark
Posts: 143
Default

Still getting a wee bit of black on hard acceleration.....is this just normal now???
E7 58reg is offline   Quick reply to this message
Old 29-06-16, 08:09 PM   #6
Senior Member
 
Join Date: Apr 2014
Location: Lanark
Posts: 143
Default

Anybody????
E7 58reg is offline   Quick reply to this message
Old 16-03-17, 12:49 PM   #7
Junior Member
 
Join Date: Oct 2016
Posts: 17
Default

Quite a comprehensive link here. see if any this helps.

Diagnose Exhaust Smoke
Ballynoes is offline   Quick reply to this message
Old 16-03-17, 06:14 PM   #8
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,775
Default

black smoke on a diesel is either not enough air (blocked air filer, maf not reading properly, turbo not spinning properly) or too much fuel ( bad injector or a wiring fault.....)
__________________
Great deals on car keys contact me 07599587119
trustme is offline   Quick reply to this message
Old 26-03-17, 06:41 PM   #9
Senior Member
 
Join Date: Nov 2016
Posts: 103
Default

Is your intercooler filling up with oil or condensation ?
martins-place is offline   Quick reply to this message
Old 27-03-17, 12:13 PM   #10
Senior Member
 
Join Date: Apr 2014
Location: Lanark
Posts: 143
Default

Quote:
Originally Posted by martins-place View Post
Is your intercooler filling up with oil or condensation ?
No, I had the bottom hose to the intercooler disconnected recently and only sign of oil was on the walls of the hose if you dragged your finger over it. Your finger was black but not wet by any means and when I disconnected the hose, no oil dripped out.
E7 58reg is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:13 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.