battery light and power steering gone - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 29-06-14, 08:32 PM   #1
ged
Inactive User
 
Join Date: Jun 2014
Posts: 1
Default battery light and power steering gone

hi guys, looking for help on this one

ive got a 99 partner and turned into the driveway and the battery light came on and the power steering cut out

now when i start the van the battery light goes on/off, and is beeping

checked the batt volt at 12.5 before starting the engine

when running idle it's 10 volt

the alternators giving out 10.5 volt

everything else electrical in the van is going but the power steering, i'm hoping theres just a bad connection somewhere, or does the alternator need replaced??
i checked the serpentine belt, it's a little slack- should it be really tight? i don't think its slipping?

any advice happily received, thanks!
ged is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-06-14, 09:05 PM   #2
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,420
Default

If no squeal from belt likely to be goosed alternator. If battery voltage drops below about 12.8v all high drain electrical items are switched off by BSI as it assumes alternator has failed and it tries to maintain battery voltage to keep car/van running as long as possible.
__________________
DS5 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Quick reply to this message
Old 29-06-14, 10:14 PM   #3
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,927
Default

A 99 model won't have electric steering though so I would check your bottom pulley is not loose causing the serpentine belt to turn slower than it should
__________________
assume nothing check everything twice !!
reliable406 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:37 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.