2009 E7 taxi turbo replaced still smoke's - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 11-02-13, 02:46 PM   #1
Inactive User
 
Join Date: Oct 2012
Location: Wolverhampton
Posts: 94
Default 2009 E7 taxi turbo replaced still smoke's

Hi have in a 2009 E7 taxi in with 2.0 HDi engine RHK only done 81000miles

Customer said the turbo went and the engine had run on its own for a bit...!

Anyway he had a garage fit new turbo and one injector..!

I have had it in to try and cure the black smoke it emits under load its like a red arrow but bellowing black smoke.

There are no faults on ecu at all...!

Took intercooler off and drained the oil out etc....!

egr valve working in live data etc...

I think maybe damaged engine internally !

Any ideas please ?
belmo04 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-02-13, 02:53 PM   #2
davidireland
Guest
 
Posts: n/a
Default Re: 2009 E7 taxi turbo replaced still smoke's

Do a compression test. Also why was there an injector changed?

Sent from my GT-S5690
  Quick reply to this message
Old 11-02-13, 03:05 PM   #3
Inactive User
 
Join Date: Oct 2012
Location: Wolverhampton
Posts: 94
Default

Thanks for that

Dont no why was changed he wasnt very clear...!

Not got a diesel compression tester !

There is no misfire and he never mentioned it lumpy or rough when starting from cold..The engine does breath if you open the oil filler.

Its like proper soot as if not fueling properly but boost etc and airflow are all good.

Have you come across this before ?

Thanks David
belmo04 is offline   Quick reply to this message
 
Old 11-02-13, 05:05 PM   #4
davidireland
Guest
 
Posts: n/a
Default Re: 2009 E7 taxi turbo replaced still smoke's

Remove the egr valve also and inspect. The end caps tend to break off them.

Sent from my GT-S5690
  Quick reply to this message
Old 11-02-13, 05:31 PM   #5
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,173
Default

Mileage is a bit low for a turbo failure to be honest has it been well serviced we had 1 of ours blowing lots of smoke but it had 150k on it still on its original turbo in fact still is now and its getting close to 200k

Ours was smoking due to worn rockers no real noise from them but after stripping it down they were obviously well worn out a new set and it was good as new again

If yours is poorly serviced they could have worn even sooner especially if it reved its nuts off while drinking its own oil
reliable406 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:38 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.