2003 Expert 1.9d glow plug relay fault - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools Display Modes
Old 03-06-14, 07:48 AM   #1
Inactive User
 
Join Date: Jun 2014
Location: bedford
Posts: 23
Default 2003 Expert 1.9d glow plug relay fault

Hi

This is one of my first posts and already asking for help....here goes.

I had an intermittent fault on some occasions my van wouldn't start from cold, now it's permanent won't start from cold otherwise runs fine

I have found that from the relay I have no voltage going to my glow plugs when I turn the ignition on, so I replaced the relay which had no effect. I have managed to check voltage readings on the following relay connects.

I have 12v going to relay from the battery (I/P) pin 8

Pin 1 connects to earth (good connection)
pin 2 no connection
pin 3 no voltage
pin 4 no voltage
pin 5 no voltage

Readings taken connector removed from relay when I turn the ignition on.

Has anyone had a similar fault, my assumptions are;

Faulty connector somewhere.
ECU (hope not)
Immobiliser (kicking in for some reason).

Any assistance would be really appreciated.

Many thanks
billy_wiz is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-06-14, 05:14 AM   #2
Inactive User
 
Join Date: Jan 2014
Posts: 2
Default

I have also just found that one of my glow plugs has no power getting to it. Where is the relay situated ? I,m sure between us we can get to the bottom of this
hammerite is offline   Quick reply to this message
Old 06-06-14, 07:33 AM   #3
Inactive User
 
Join Date: Jun 2014
Location: bedford
Posts: 23
Default

Hi

The glow plug relay is mounted on the inner wing on the left hand side, it's about 3-4 inches long, has 1 plug connector and 2 terminals.

It's easy to get too.

good luck
billy_wiz is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 10:19 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.