Temp high, STOP light on after 10 mins driving- - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Announcements, Comments, Help > Peugeotforums.com Forum Technical Support or Site Issues
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-10-15, 07:02 PM   #1
Inactive User
 
Join Date: Oct 2015
Posts: 2
Default Temp high, STOP light on after 10 mins driving-

Hi, can someone help me please.
My 2005 206 temperature rises rapidly and the STOP light comes on and bleeps after 10 mins driving.
If I turn the heater on it drops off the red.
Heater is hot
Water is still in the bottle.
Suddenly happened today on a short trip.

Any help is great, thank you
Roxypop is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-10-15, 08:12 PM   #2
Inactive User
 
Join Date: Aug 2015
Location: Buckley, North Wales
Posts: 202
Default

failed thermostat? i.e failed in the closed position so the water never reaches the radiator to cool. seems to fit the symptoms described
adam19952013 is offline   Reply With Quote Quick reply to this message
Old 09-10-15, 08:58 PM   #3
Inactive User
 
Join Date: Oct 2015
Posts: 2
Default

Quote:
Originally Posted by adam19952013 View Post
failed thermostat? i.e failed in the closed position so the water never reaches the radiator to cool. seems to fit the symptoms described
Would the heater still be hot? And water in the expansion tank only warm?
Thanks
Roxypop is offline   Reply With Quote Quick reply to this message
 
Old 09-10-15, 09:09 PM   #4
Inactive User
 
Join Date: Aug 2015
Location: Buckley, North Wales
Posts: 202
Default

i'm not overly familiar with the 206 coolant system but most likely yes. the thermostat is usually between the block and heater matrix, and the top pipe to the radiator. therefore if the thermostat stays shut, the block and heater matrix both get very hot very quickly. the heater is basically a mini radiator, hence the decrease in temperature when the heater is on.

do the hoses to the radiator get warm? if the bottom hose remains cool/cold, its probably a failed thermostat. the top hose will be hotter than the bottom hose but there still should be heat in the bottom hose.

alternatively, it could also be a failed water pump.
adam19952013 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:13 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.