No Dash Lights and car will not turn over/start - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans > Partner
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 29-10-17, 05:50 AM   #1
Junior Member
 
Join Date: Oct 2017
Posts: 7
Default No Dash Lights and car will not turn over/start

Hi, hoping someone knows what might be the issue with my partner van.

van died on me last night and had to get towed home. engine cut out and all power from dash related electronics stopped working. I have interior light and central locking and radio works. I have no power to windows, dash, cig lighter and engine wont turn. anyone got any ideas of where to start. AA man said its unlikely an immobilizer issue as it wouldn't stop the power coming on. he couldn't connect a diagnostic machine as he said he needed ignition on. thanks in advance.
r3ynolds is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-10-17, 07:52 AM   #2
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,143
Default

HI....start by checking the battery voltage and let us know ...good luck
noddy-hol is online now   Reply With Quote Quick reply to this message
Old 29-10-17, 12:31 PM   #3
Junior Member
 
Join Date: Oct 2017
Posts: 7
Default

hi, the battery is fine. all electric work that dont need the ignition on. remote central locking also works.
r3ynolds is offline   Reply With Quote Quick reply to this message
 
Old 29-10-17, 01:16 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,049
Default

Earth wire from body to engine and gearbox check its secure and in good nick.

Is the van damp inside ?
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 29-10-17, 01:37 PM   #5
Junior Member
 
Join Date: Oct 2017
Posts: 7
Default

no damp. checked earths seem all ok. the sensor in the ignition is detecting the key as it wont lock doors via remote if key is in and turned (used key without battery in ignition and working remote locks doors)
r3ynolds is offline   Reply With Quote Quick reply to this message
Old 29-10-17, 01:59 PM   #6
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,143
Default

I would now look at the starter motor ,to make sure it hasnt failed..
noddy-hol is online now   Reply With Quote Quick reply to this message
Old 29-10-17, 02:09 PM   #7
Junior Member
 
Join Date: Oct 2017
Posts: 7
Default

I have already been under and check starter wiring but don't see why the starter failing would stop the dash light coming on when key is turned. the car was running for about 3 hours before it cut out. is it possible it the ignition switch itself. was thinking as the sensor is picking up the key, would i be able to unplug the other cable and see if i can use a bit of wire to hot wire it HAHA. also the mileage still works and when van goes into eco mode battery light comes on and goes off when opening doors.

Last edited by r3ynolds; 29-10-17 at 02:15 PM.
r3ynolds is offline   Reply With Quote Quick reply to this message
Old 29-10-17, 02:37 PM   #8
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,143
Default

Hi..I have had starters fail in a way that draws lots of current from the battery..enough to stop the car....but as the battery recovers a bit ,there is enough to power small items.You can try and energise your starter by using a wire from the battery to the small terminal on the starter and see what happens(not the big thick wire)to eliminate that.
noddy-hol is online now   Reply With Quote Quick reply to this message
Old 29-10-17, 03:11 PM   #9
Junior Member
 
Join Date: Oct 2017
Posts: 7
Default

ok, just done starter motor test and it turns over no problem.
r3ynolds is offline   Reply With Quote Quick reply to this message
Old 29-10-17, 03:17 PM   #10
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,143
Default

Ok...check all fuses and fuse box and cables leading to it
noddy-hol is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:16 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.