Peugeot dashboard - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > General > Off-topic
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 16-06-15, 11:53 PM   #1
Inactive User
 
Join Date: Jun 2015
Posts: 3
Default Peugeot dashboard

Hello. Today I was trying to connect my dvd player and touched. Minus and plus by accident for very short time. And after that my dashboard completely doesn't work and hazard lights button don't work and original cd player don't work no more. I checked all possible fuses in car and under the bonnet. Can someone help me? My car is Peugeot 1.4 hdi year 2003. Please help! I triple checked fuses. Tried to disconnect battery for 10 minutes too. Nothing...
Evilcamper is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 17-06-15, 12:16 AM   #2
Inactive User
 
Join Date: May 2015
Location: Wirral
Posts: 364
Default

You may do better posting this thread under the releavant section for your car. If you have checked ALL the fuses and they are all ok you will really have to get the car hooked up to diagnostics check here https://www.peugeotforums.com/forums/...anet-map-7734/ see if there is a member local to you and speak to them. Alternatively a Peugeot independent garage but do check ALL the fuses first. If you do find a blown fuse disconnect the battery following the three minute rule before replacing it and always follow reconnection procedure when reconnecting the battery. Remember always disconnect the battery before carrying out any electrical work no matter how small, you will find the procedures here http://www.petercoopercarrepairs.co...._procedure.htm
__________________
Andy Pug 206 There's No Substitute For Experience

Last edited by renegade; 17-06-15 at 12:22 AM.
renegade is offline   Reply With Quote Quick reply to this message
Old 17-06-15, 12:20 AM   #3
Inactive User
 
Join Date: Jun 2015
Posts: 3
Default

Checked every single fuse... I am desperate. I have no money what so ever... Just willing that anyone can give me a helping hand.
Evilcamper is offline   Reply With Quote Quick reply to this message
 
Old 17-06-15, 12:27 AM   #4
Inactive User
 
Join Date: May 2015
Location: Wirral
Posts: 364
Default

Don't know what members charge for a diagnostic as it tends to be by personal arrangement and some members offer more services than others, unfortunately if it isn't a fuse a diagnostic is one of the only things that can try and establish the problem and is certainly the easiest to impliment.
__________________
Andy Pug 206 There's No Substitute For Experience
renegade is offline   Reply With Quote Quick reply to this message
Old 18-06-15, 09:26 PM   #5
Inactive User
 
Join Date: Jun 2015
Posts: 3
Default

Anyone any solution please or ideas what could it be?
Evilcamper is offline   Reply With Quote Quick reply to this message
Old 19-06-15, 01:00 AM   #6
Inactive User
 
Join Date: May 2015
Location: Wirral
Posts: 364
Default

To be honest if you are sure all the fuses are OK then it is probably a fried BSI but it will need a diagnostic to prove this as the solution can be costly. Without actually examining the car I can't advise you further but I would urge you to double/triple check it is not a fuse.
__________________
Andy Pug 206 There's No Substitute For Experience
renegade is offline   Reply With Quote Quick reply to this message
Old 21-07-15, 02:49 PM   #7
Inactive User
 
Join Date: Apr 2014
Posts: 12
Default

This happened to me once before, accidentally shorted the boot light on my 406 and the dash woudn't work, no overhead lights etc, turned out to be 1 popped fuse. New one in and problem solved. As others have said, check again thoroughly, I bet it's in there.
__________________
[color=#000080][b]2001/Y Peugeot 406 2.0 HDi[/b] [/color]
fattail95 is offline   Reply With Quote Quick reply to this message
Old 21-07-15, 04:17 PM   #8
Senior Member
 
storeman's Avatar
 
Join Date: Jan 2013
Location: Oldham, UK
Posts: 5,905
Default

What model ?

Have you checked the BSI fuses as well as the under bonnet fuses ?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
storeman is offline   Reply With Quote Quick reply to this message
Old 22-07-15, 07:14 AM   #9
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,575
Default

OP hasn't bothered to come back since 18th June.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 03:38 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.