Peugeot expert problem - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans > Expert
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By reliable406

Reply
 
LinkBack Thread Tools Display Modes
Old 09-12-13, 10:03 PM   #1
Junior Member
 
Join Date: Dec 2013
Location: North Wales
Posts: 4
Default Peugeot expert problem

First of all just want to say Hi as this is my first post after getting the link from a friend.We have peugeots throughout the family so I think the forum would help a lot.My first cry for help and it is a cry as my head is battered with it.I have an 04 expert 2ltr hdi and the problem first showed up last year but only for a day or so then vanished but now has showed itself constantly for the last fortnight.The van starts fine but once on the move will randomly try to cut out.The yellow engine management light will come on,van slows instantly as if its going to stall,light goes out and van picks up speed.If im approaching a stop with low revs and the light comes on it will cut out completely with steering lock on.Van will start fine until it happens again and so on.It went on to diagnostics last week and the mechanic said it showed an airflow and a power relay problem.Hes checked the airflow and the mix is fine.Also put another airflow valve on and a new power relay.Started this morning and within 50 yards the light flickered and the van shuddered again,happened about a dozen times after.Please can anybody help as its ruining me,cheers for any input,Daz.
dazdecs7 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-12-13, 07:37 AM   #2
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,622
Default

https://www.peugeotforums.com/forums/...gnostic-28190/
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 10-12-13, 06:54 PM   #3
Junior Member
 
Join Date: Dec 2013
Location: North Wales
Posts: 4
Default

Thanks gibbo..20 posts done.
dazdecs7 is offline   Reply With Quote Quick reply to this message
 
Old 10-12-13, 07:03 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,049
Default

Engine wiring harness problems are common on these the joints inside the loom become bad causing all sorts of symptoms.

One other thing could be a bad injector leaking back too much fuel causing the fuel pressure to drop on idle or under light load only way to tell is get a leak off test done
belmo04 likes this.
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:49 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.