Peugeot Expert 2009 2.0HDi 120 - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans > Expert
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By reliable406

Reply
 
LinkBack Thread Tools Display Modes
Old 16-09-13, 11:06 AM   #1
Inactive User
 
Join Date: Sep 2013
Posts: 3
Default Peugeot Expert 2009 2.0HDi 120

Hi all, I have an expert van (2009) which every now and again throws fault codes into my display. some of the faults are: faulty power steering, antipollution faulty and so forth. The EOBD or engine management light comes on too. The STOP light comes on also, when all of this happens, if i stop the van it wont restart for anything up to an hour later, it basically immobilises the van. On recommendation I have changed the engine bay fuse box, and have had peugeot dealership check the van over, but the problem keeps re-occuring and it is making for a unreliable van especially as I'm self-employed etc.. Can anyone offer suggestions or solutions to my problem please as I'm really frustrated with the van by now. Many thanks, Matt
Matt-DFC is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 16-09-13, 12:10 PM   #2
COLINELLIS
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Matt-DFC View Post
Hi all, I have an expert van (2009) which every now and again throws fault codes into my display. some of the faults are: faulty power steering, antipollution faulty and so forth. The EOBD or engine management light comes on too. The STOP light comes on also, when all of this happens, if i stop the van it wont restart for anything up to an hour later, it basically immobilises the van. On recommendation I have changed the engine bay fuse box, and have had peugeot dealership check the van over, but the problem keeps re-occuring and it is making for a unreliable van especially as I'm self-employed etc.. Can anyone offer suggestions or solutions to my problem please as I'm really frustrated with the van by now. Many thanks, Matt
Power steering fault may mean that you need the fluid topping up my 407 used to do this then stopped when I topped up the fluid. As for the faults etc get a diagnostics etc done

https://www.peugeotforums.com/forums/...gnostic-28190/

new updated map

https://maps.google.com/maps/ms?msid...75332,28.54248

Also update your profile with your location etcand put a signature with your vehicles details as it will help members a lot with advice
  Reply With Quote Quick reply to this message
Old 16-09-13, 01:17 PM   #3
Inactive User
 
Join Date: Sep 2013
Posts: 3
Default expert van

Hi, thanks for that info. I have checked all fluid levels and they are at correct max levels. I have noticed that my collant reservoir is leaking and periodically drains itself but have been told by peugeot that this wouldnt bring all the warning lights on?
Matt-DFC is offline   Reply With Quote Quick reply to this message
 
Old 16-09-13, 04:37 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,049
Default

The faults you mention are all coming on due to low voltage we get it from time to time on our taxis BUT they never fail to start.

Check for bad earths round the battery and any earths under bonnet as your power steering is electric and needs a good supply if the BSI sees voltages all over the place it gets confused the stop light comes on with steering faults.

Antipollution fault can also be caused by voltage spikes.
Gibbo likes this.
reliable406 is offline   Reply With Quote Quick reply to this message
Old 16-09-13, 08:16 PM   #5
Inactive User
 
Join Date: Sep 2013
Posts: 3
Default Expert van

Thanks reliable406. That seems very logical. I will try this ASAP. Thanks for your time in replying. Matt
Matt-DFC is offline   Reply With Quote Quick reply to this message
Old 18-09-13, 09:32 AM   #6
Inactive User
 
Join Date: Oct 2012
Location: Wolverhampton
Posts: 94
Default

Sounds like Power steering pump is on its way out ! They draw a lot of current and are also linked to the can bus network which can cause a non start..!
belmo04 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:58 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.