2007 2.0hdi ecu wiring - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans > Expert
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 20-04-19, 03:50 PM   #1
Junior Member
 
Join Date: May 2018
Posts: 11
Default 2007 2.0hdi ecu wiring

My 2007 2.0hdi does not start. It seems that the ecu is not waking up, but I can not find wiring schematics anywhere. It is a Siemens/VDO unit.
I have googled, tried Haynes rep. books and also servicebox.peugeot.com, but can`t find any that helps.
The wiring harness on these cars often rot I have heard, but I have no clue which wires to check for voltage to find the problem, nor where to start looking.
I have done the obvious check`s with battery voltage and all the fuses.
Does anybody have some tips on where, or what wires to check?
Thanks!
Romw is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 20-04-19, 10:03 PM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

2007 could be old version or new version and where to look for issues varies a huge amount
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 21-04-19, 03:04 PM   #3
Junior Member
 
Join Date: May 2018
Posts: 11
Default

Quote:
Originally Posted by reliable406 View Post
2007 could be old version or new version and where to look for issues varies a huge amount
Sorry forgot to mention that the van is the newer version.

What I am trying to find out is which wires to the ecu is powering it, and or which wires "wakes it up". The wires are numbered and they are colour coded as well.
I hoped there was a wiring diagram or a ecu pinout reference or something that would make it easier to check the right wires. And not just fiddling around with the wire harness, checking wires there are no need to check.
Romw is offline   Reply With Quote Quick reply to this message
 
Old 21-04-19, 03:50 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

The numbers are what you want colours don't really follow any logic worth repeating
There are lots of powers and earth as for what wakes it up the BSI sends a signal once ignition is turned on this is compared with code in ecu if it matches the ecu sends a handshake back to the BSI and the ecu is ready to go.

Have you done the beep test.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 23-04-19, 07:05 PM   #5
Junior Member
 
Join Date: May 2018
Posts: 11
Default

Quote:
Originally Posted by reliable406 View Post
The numbers are what you want colours don't really follow any logic worth repeating
There are lots of powers and earth as for what wakes it up the BSI sends a signal once ignition is turned on this is compared with code in ecu if it matches the ecu sends a handshake back to the BSI and the ecu is ready to go.

Have you done the beep test.
First of all,
Thanks Reliable406 for helping out here!!

No, i Have not done the beep test.
Sorry, but I do not know how to perform a beep test.
Romw is offline   Reply With Quote Quick reply to this message
Old 23-04-19, 07:17 PM   #6
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

do a search you NEED to do it first before wasting time on other things
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 24-04-19, 09:09 PM   #7
Junior Member
 
Join Date: May 2018
Posts: 11
Default

I did the beep test today, and the car "beeped" when I left the key in.
Romw is offline   Reply With Quote Quick reply to this message
Old 24-04-19, 09:15 PM   #8
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

That's good your best bet now is to get some live data readings as this will tell you if ecu is getting power and what it is seeing

Any history you may need to tell us when did it last run did it cut out etc
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 25-04-19, 08:42 AM   #9
Junior Member
 
Join Date: May 2018
Posts: 11
Default

I have tried four different diagnostic tool`s and none of them finds the ecu or the abs controller.
The only thing the diagnosis finds is the airbag "system".

The van has mainly been used daily to work, driving it 35km each way.
Have never had any problem until this winter. The van had been still for a week.
Started and moved the van during some snowmoving, let it idle for 20-30min. And shut it of.
A week later it did not start, and throwed a fault code "antipollution system faulty" in the display. It does not engage starter or start prewarming.
The starter runs, when wiring it directly, so starter motor is fine.
I then hooked up some diagnostics to retrieve the fault codes, but no ECU to be found.
Checked all the fuses, and called a local peugeot workshop to get some hints in case it was a problem with the antitheft system. But they responded that the car would run the starter motor but not start if the antitheft system was active. The workshop suggested that the ECU was destroyed, so I got a used one and swapped it out, but nothing happened. So it leads me to think that the ECU is not getting power, or a signal to power up.
Romw is offline   Reply With Quote Quick reply to this message
Old 26-04-19, 03:08 PM   #10
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

You CANNOT swap the ecu on its own put your original one back !

Check the fuses UNDER the underbonnet fusebox also the ones next to the battery get all wet and rot check the HOLDERS not just the fuses
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 2.0Hdi Expert no glow, no diesel pump, no starter. Romw Expert 0 16-02-19 11:25 AM
Difference in 2.0HDI 140 & 2.0HDI 163BHP ? Vaz 508 (2011-18) 13 31-05-17 07:43 PM
Towbar & wiring 2006 2.0HDi geoff40752 407 2 07-10-13 06:26 PM
2007 Expert 2.0HDi won't start when warm actionman Expert 11 28-06-12 06:02 PM


All times are GMT. The time now is 02:04 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.