Lexia 3 Runtime error - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Tuning & Modifications > Detailing and Gadgets
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 29-06-18, 08:16 AM   #1
Junior Member
 
Join Date: Nov 2012
Posts: 7
Default Lexia 3 Runtime error

Hi everyone,

I didn't want to hijack anyone else's thread so thought I would post another, I hope that's ok.

Last night I installed Lexia 3 on a windows 8 64 bit laptop and it works fine apart from small niggling issue.

When ever I launch the application it gives me an error message saying that Net Framework 3.5 isn't installed and do I want to download it and install.

As I already have a higher version of Net Framework installed as part of the windows 8 base build is there anyway I can stop the software running a check for Net Framework 3.5 or tell the software I have a higher version?

As you can tell I am new to Lexia (only got my Peugeot a week ago) and it looks more confusing than the VW VCDS I am used to. Are there any good user guides or tutorials how to use the software?

When I was learning to use VCDS there was so many resources including the manufacturers site (rosstech) however there doesn't appear to be the same coverage of support materials for Lexia.


Thanks everyone for taking the time to read this and hopefully offering some advice.

Noel
Pioneer_36 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-06-18, 11:35 AM   #2
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,578
Default

Can't speak for your OS, but from experience I've only used Windows XP and 10, both 32 bit, and both work fine with no errors.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 29-06-18, 11:46 AM   #3
Senior Member
 
Join Date: May 2018
Posts: 165
Default

It doesn't matter if you have a higher version or not, apps target a specific version sometimes depending on what they were written with

Install .net 3.5, no more error message! (you can install 3.5 behind 4/4.5 and above, they run side by side)
Stubbo is offline   Reply With Quote Quick reply to this message
 
Old 29-06-18, 11:50 AM   #4
Junior Member
 
Join Date: Nov 2012
Posts: 7
Default

I tried to install 3.5 also but it wont let me as 4.0 is installed, I'll have another go and see if I can get it to work.
Pioneer_36 is offline   Reply With Quote Quick reply to this message
Old 29-06-18, 11:55 AM   #5
Senior Member
 
Join Date: May 2018
Posts: 165
Default

How are you doing it?

On windows 10 i either do it using the control panel > programs and features > Turn windows features on or off

Or using DISM if you're comfortable doing that

Both ways will need the windows CD/USB media
Stubbo is offline   Reply With Quote Quick reply to this message
Old 29-06-18, 12:12 PM   #6
Junior Member
 
Join Date: Nov 2012
Posts: 7
Default

I'm doing it via cmd prompt. It is possible the ISO I have for windows 8.1 64 bit pro has a problem (downloaded it ages ago).

I'll download another version tonight and see if that fixes the problem.
Pioneer_36 is offline   Reply With Quote Quick reply to this message
Old 29-06-18, 12:15 PM   #7
Senior Member
 
Join Date: May 2018
Posts: 165
Default

You running this command? (assuming your CD drive (or mounted ISO file) is D)

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:D:\sources\sxs
Stubbo is offline   Reply With Quote Quick reply to this message
Old 29-06-18, 01:11 PM   #8
Junior Member
 
Join Date: Nov 2012
Posts: 7
Default

That looks like the command, I have it saved on my laptop so will check when I get home.
Pioneer_36 is offline   Reply With Quote Quick reply to this message
Old 04-07-18, 06:34 AM   #9
Junior Member
 
Join Date: Nov 2012
Posts: 7
Default

Finally got it all working without the prompt to install NetFramework 3.5 by installing windows from scratch and removing NetFramework 4.0 via control panel and then installing v3.5 and enabling v4 again.

No sure why it wouldn't install v3.5 before that but at least its working now and the Lexia (Diagbox) software runs as expected and is able to talk to the car and do a full scan, now I just need to figure out how to use the rest of it.

Thanks for all the help from everyone who replied.

Noel
Pioneer_36 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:11 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.