New Boxer van with a few issues. - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans > Boxer
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-11-18, 04:49 PM   #1
Member
 
Join Date: May 2010
Posts: 53
Default New Boxer van with a few issues.

I have just bought a 2014 Boxer (pre facelift) with the 2.2 Ford engine and it has a few niggle that I would appreciate a steer on.

1) All the indicator bulbs are OK but when I put left or right indicator on it claims a bulbs is faulty.

2) Both the number plate bulbs are fine but again it claims they are faulty.

3) The outside Temp reads ---C. I am guessing the sensor has failed but anyone know where it is hidden?

4) It has done 103k with 4 stamps and it is being serviced now before I collect it. I had a wonderful (Not) learning curve with the injector seals on my daughters 1.6HDi and I wondered if these 2.2 Ford engines have anything that I need to watch out for?

5) Can I just add the stalk and turn Cruise on using PP2000?

6) The van has just had a brand new screen fitted but there is no wires inside and yet a button for a quick clear screen. Has someone fitted the wrong screen or is there an electric booster heater in the ducting that blows warm air?

Thanks all.

Last edited by mark smith; 04-11-18 at 04:56 PM.
mark smith is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-11-18, 06:55 PM   #2
Junior Member
 
Join Date: May 2012
Location: Swad
Posts: 21
Default

Hi,

For the bulb problem, physically check bulbs as the Boxers suffer from water ingress to back lights and number plate bulb holders

Temp sensor is in bottom of drivers side mirror


Engines are pretty tough as long as services to manufacturers recommended interval. Only big problem is when they 1st went on sale they suffered from serious water ingress into engine bay and caused serious issues. Just make sure engine has top cover on

Yes you can add stalk on diagbox but you need adapter as van is fiat based


No heated screen fitted but just a quick clear button that uses air con to demist windscreen fast
johnnym1975 is offline   Reply With Quote Quick reply to this message
Old 16-11-18, 02:41 PM   #3
Member
 
Join Date: May 2010
Posts: 53
Default

There was corrosion in the number plate bulb holder but a clean up and new bulbs and all is fine.

The indicators are not playing the game though. I stripped the rear lights apart and they looked fine, cleaned them anyway and new bulbs. New bulbs in the front as well and undid, cleaned and re-tightened the earths by the tail light but all to no avail. The bulbs are all bright and flicker free but the dashboard is not happy.

Any ideas what I am missing here? Current sensing in the indicator relay perhaps?

There is an audible reverse warning (annoying whistle) from the rear when reverse is selected. It is plugged in on a 2 pin plug by the drivers side rear light cluster. I have unplugged it and the parking sensors etc all seem OK, any reason I can't leave it unplugged?

Thanks....

Last edited by mark smith; 16-11-18 at 03:51 PM.
mark smith is offline   Reply With Quote Quick reply to this message
 
Old 16-11-18, 10:16 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,928
Default

Fit an extra earth on each rear light unit its a common issue
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 17-11-18, 03:56 PM   #5
Member
 
Join Date: May 2010
Posts: 53
Default

Soldered an earth wire inside both rear lights, crimped a ring on and bolted it on with the normal earths by the rear lights. As before the indicators are fine but the dashboard isn't happy.

Any other ideas guys? Thanks...
mark smith is offline   Reply With Quote Quick reply to this message
Old 29-11-18, 05:28 AM   #6
Member
 
Join Date: May 2010
Posts: 53
Default

Still not fixed this fault so the next thing is to check the wiring from the BSI to each bulb and also the earths on the headlamps and mirror bulbs. I have the schematic for the BSI but where exactly is the BSI placed? Thanks.
mark smith is offline   Reply With Quote Quick reply to this message
Old 11-12-18, 09:40 PM   #7
Junior Member
 
Join Date: Dec 2018
Posts: 1
Default 2016 boxer swb van--recently purchased

Hi All, I need some advice regarding the oil level lights. I bought a 2016 swb peugeot boxer vam 2.2 litre. 55k miles on the clock. On purchase, I had the van serviced by the dealer, and all was well.....until today. I have been starting the engine as normal, and the van and dash lights are functional and everything is fine. However today, after a delivery, I switched back on the van and the oil level lights had gone from 5 full lights to 1 full light. Can anyone shed any light on this subject please? I can't see any leaks or get any burn smells.
JON KEARNS is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:40 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.