2005 Boxer Z 2.0 running limp mode until engine at optimal temp - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans > Boxer
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 13-05-19, 06:28 PM   #1
Junior Member
 
Join Date: May 2019
Posts: 1
Red face 2005 Boxer Z 2.0 running limp mode until engine at optimal temp

Hello,
So basically having issue with my van

It runs in limp mode when engine is cold not revving over 2500rpm and 80km/h
Black smoke 💨 will appear under heavy load
Has no engine power going up hills

BUT

When the temperature gauge reaches the optimal point and you turn off the engine & restart it runs normal, will rev over 2500rpm and has power to go 150km/h

First mechanic said was fuel filter...So already changed the fuel filter and air filter also new oil filter.

No service light appears on dash

Plugged in a OBD reader and no error codes appear

Any suggestion what could be the problem?
roxyboxer is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 1.4 8v petrol limp mode 1007 TonyG064 1007 0 26-02-19 02:56 PM
Limp mode but no code or lights 2.0hdi 2004 boxer crossfire89 Boxer 4 27-07-18 06:05 PM
Boxer limp mode. Ken Johnson Boxer 1 03-09-17 08:13 PM
Boxer in Limp mode Code P15BE LWS Boxer 2 13-01-17 10:03 AM
Limp mode? car slowing down until stall Roidrage69 307 17 21-09-14 12:22 PM


All times are GMT. The time now is 11:15 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.