2004 Peugeot boxer 2.2 hdi problems running rough - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > Vans > Boxer
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-07-19, 06:48 PM   #1
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

Hi all new here so hello.for starters and thanks in advance for any help ! Ive had a browse but still not sure on my problem (im no mechanic)

So to start i believe my turbo went one day driving home , the revs went wild and smoking like hell but cut out eventualy , after this i managed to get it home the next day smoking but running and wouldnt go past around 2000 rpm ! Ive replaced the turbo and intercooler (second hand ) gave it a full serice but its still running badly , ive had it plugged in while the turbo and so on was done and got the results in the pic below !!! Its idling really rough which im thinking is tge maf but doesnt make loads of difference unplugging that but it does make a slight difference , im thinking injectors as there is still some smoke and although it does rev past 2000 rpm now after turbo and so on its not running right at all ! It feels still bogged down , smoking although nothing like before when turbo went and hunting in neutral maybe a slight knocking although bad injectors can cause all of this cant it ?

Thanks for any help people its much appretiated
Attached Thumbnails
received_387992885160233_1562438885174.jpg  

Last edited by Paddybee; 06-07-19 at 07:47 PM.
Paddybee is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-07-19, 07:39 PM   #2
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

I'll just add it starts first time no issue there and i have ordered a coolant sensor and new maf sensor ! I did notice that air box side of the maf sensor was joined but loose no jubilee clip for a nice seal , also i get a high oil warning on dash although that has been drained and replaced , was doing that before turbo went as well ??
Paddybee is offline   Reply With Quote Quick reply to this message
Old 07-07-19, 09:15 AM   #3
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

Bit more info if it helps , there seems to be a slow leak from somewhere , not dripping on the ground but looks to be coming from above somewhere and running down possibly ! And around one of the injectors there seems to be a small amount of oil has settled in a little rut around the injector , ive done the screwdriver test and all seem to be opening and closing including that one ! Theres a couple of videos if it will let me upload them
Paddybee is offline   Reply With Quote Quick reply to this message
 
Old 07-07-19, 09:19 AM   #4
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

https://youtu.be/FDQctOLd_1o
Paddybee is offline   Reply With Quote Quick reply to this message
Old 07-07-19, 09:20 AM   #5
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

https://youtu.be/fr50GXqmpfM
Paddybee is offline   Reply With Quote Quick reply to this message
Old 07-07-19, 09:20 AM   #6
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

https://youtu.be/eJ9VvvGWn9I
Paddybee is offline   Reply With Quote Quick reply to this message
Old 08-07-19, 01:49 PM   #7
Junior Member
 
Join Date: Jun 2019
Location: Preston, Lancashire
Posts: 10
Default

Wish I could help mate but diesels are beyond my ken.

Frank
Traficman is offline   Reply With Quote Quick reply to this message
Old 08-07-19, 02:16 PM   #8
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

Im hoping someone comes along that does know but not looking great, thanks anyway
Paddybee is offline   Reply With Quote Quick reply to this message
Old 08-07-19, 04:10 PM   #9
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,928
Default

You have done damage internally when you allowed it to run away you should always try to control the runaway by using a high gear and braking to slow the engine safely.

It is possible a couple of rockers have jumped off it is also possible an injector has a melted tip or it could have melted a piston causing low compression in 1 cylinder so you now need to decide which it is !
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 08-07-19, 04:32 PM   #10
Junior Member
 
Join Date: Jul 2019
Posts: 8
Default

Thanks , so a compretion test comes back ok your thinking injectors or rockers ?
Paddybee is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:07 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.