Airbag warning light - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Tuning & Modifications > Bodyshop Techniques & Modifications
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 27-07-13, 07:06 PM   #1
Inactive User
 
Join Date: Jul 2013
Location: Brum
Posts: 36
Default Airbag warning light

Hi

I recently acquired, from my dad, his old 52 reg (Feb 2003) 307 Rapier estate HDI 90.

About 3 years ago, he had it valeted, steam cleaned seats etc. The next day the airbag light came on. He has pretty much ignored it, he had a diagnostic (private garage) done a few months ago and they pointed to the comm2000 unit. The MOT is not due till Feb 14 but I have been told it will be a fail under new rules.

Does anyone think anything could have happened during the valet to make the light come on, I have disconnected and reconnected the under seat connectors to no avail, or do you think it's probably just coincidence the light came on afterwards.

If it is the comm2000 unit, if I were to buy one with the trip button on the end of the wiper stalk, would this work in my car as it has not got it now? I guess I would need to avoid the units with auto wipers/lights etc.

Lastly would you think it a good idea to get a second hand one? If these are prone to failure would I be better to get a new one from ebay?

Your thoughts would be appreciated.

Cheers
pauljredmond is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 27-07-13, 07:08 PM   #2
Senior Member
 
border_all's Avatar
 
Join Date: May 2013
Location: Teesside
Posts: 1,859
Default

Hi

No idea on answer but this was just posted

https://www.peugeotforums.com/forums/...ad.php?t=39794

Might help



Sent from AutoGuide.com App
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
border_all is offline   Reply With Quote Quick reply to this message
Old 27-07-13, 07:14 PM   #3
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,775
Default

Quote:
Originally Posted by pauljredmond View Post
Hi

I recently acquired, from my dad, his old 52 reg (Feb 2003) 307 Rapier estate HDI 90.

About 3 years ago, he had it valeted, steam cleaned seats etc. The next day the airbag light came on. He has pretty much ignored it, he had a diagnostic (private garage) done a few months ago and they pointed to the comm2000 unit. The MOT is not due till Feb 14 but I have been told it will be a fail under new rules.

Does anyone think anything could have happened during the valet to make the light come on, I have disconnected and reconnected the under seat connectors to no avail, or do you think it's probably just coincidence the light came on afterwards.

If it is the comm2000 unit, if I were to buy one with the trip button on the end of the wiper stalk, would this work in my car as it has not got it now? I guess I would need to avoid the units with auto wipers/lights etc.

Lastly would you think it a good idea to get a second hand one? If these are prone to failure would I be better to get a new one from ebay?

Your thoughts would be appreciated.

Cheers
your unit could be repaired or you could buy a second hand one i have a few for sale with 6 months warranty you could get one with trip button but you would need to enable it with pp2000 to get it working
trustme is offline   Reply With Quote Quick reply to this message
 
Old 27-07-13, 07:21 PM   #4
Inactive User
 
Join Date: Jul 2013
Location: Brum
Posts: 36
Default

Thanks both.

From what I have read there are a couple of different manufacturers that were used for these units. I guess I will have to get the steering wheel off at some point to have a look at the label.
pauljredmond is offline   Reply With Quote Quick reply to this message
Old 27-07-13, 07:23 PM   #5
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,775
Default

Quote:
Originally Posted by pauljredmond View Post
Thanks both.

From what I have read there are a couple of different manufacturers that were used for these units. I guess I will have to get the steering wheel off at some point to have a look at the label.
delphi and dav but that does not matter both will work the same as long as its a comm 2000 and not a comm 2001
trustme is offline   Reply With Quote Quick reply to this message
Old 27-07-13, 07:26 PM   #6
Inactive User
 
Join Date: Jul 2013
Location: Brum
Posts: 36
Default

Ah, how do I find that out? My dad told me it was the bit behind the steering wheel, I came up with the name comm2000 unit from googling
pauljredmond is offline   Reply With Quote Quick reply to this message
Old 27-07-13, 10:11 PM   #7
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,416
Default

Get the codes read with Planet by a local member first it could still be seat connectors etc

comm 2000 is behind steering wheel combines all stalks and airbag connections to steering wheel. Driver trigger 1/2 faults often related to comm2000
john_h likes this.
__________________
DS5 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is online now   Reply With Quote Quick reply to this message
Old 27-07-13, 10:13 PM   #8
Inactive User
 
john_h's Avatar
 
Join Date: Nov 2009
Location: Gateshead - Tyne and Wear
Posts: 4,512
Default

As windy says...get those codes read!

chances are the wiring on the seat connectors has broke and is causing the issue.



john_h is offline   Reply With Quote Quick reply to this message
Old 27-07-13, 10:37 PM   #9
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,775
Default

Quote:
Originally Posted by pauljredmond View Post
Ah, how do I find that out? My dad told me it was the bit behind the steering wheel, I came up with the name comm2000 unit from googling
its defo a comm 2000 unit on that car but as said i might not even be the comms unit at fault and until you have the codes read it could be anything on the airbag system
trustme is offline   Reply With Quote Quick reply to this message
Old 27-07-13, 11:32 PM   #10
Inactive User
 
Join Date: Jul 2013
Location: Brum
Posts: 36
Default

I have checked, un plugged and re plugged the under seat connectors, they did not look disturbed in any way. I also had a look under the plastic trim under the door post at the yellow connector beneath the carpet. All seems fine, as I said my dad did have a diag done when it was his car by a private garage and he was told it was the comm unit.

As far as checking this out for my self, would this or similar do the trick?

Scanner Scanner
pauljredmond is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:59 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.