Turbo or not - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > MPVs > 806/807
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 25-05-13, 07:45 PM   #1
Member
 
Join Date: Oct 2012
Posts: 40
Default Turbo or not

Hi there again just need some conformation on the cars new fault I have just got car back from mot after it failed on some bits but on way to test it came up unblock particle filter so fitted new filter back to test station car drove better but no real power or turbo. Now back from test and checked all levels topped oil and water,the water level was in middle and oil just below max also topped up all ok so drove car home from work 5min max journey noticed noise from o/s/f and blue smoke and not a lot of power, then went back to work and the same again.

When I get to work I stop and get out and rev engine some blue smoke but when engine gets to 3000rpm seems to miss fire a few times clouds of smoke then it continues to rev with some smoke .noise I mentioned is engine related not speed I am I right in saying turbo failure

Thanks for reading another of my long messages
Cheers bob
pullitt73 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 25-05-13, 07:46 PM   #2
davidireland
Guest
 
Posts: n/a
Default

Why change the particle filter?
Have you had a diagnostic check done?
What engine? You are only trickleing info!!
  Reply With Quote Quick reply to this message
Old 25-05-13, 08:07 PM   #3
Member
 
Join Date: Oct 2012
Posts: 40
Default

Hi Dave on way to test station motor lost power lots of smoke and one point engine cut out one second throttle next nothing and there on diagnostics except turbo solenoid open circuit this where I put the two plugs in wrong way round and i swapped plugs around and the other was dpf blocked nothing else engine wise in ecu (open circuit on Webasto) have not done scan yet as I am now at work
pullitt73 is offline   Reply With Quote Quick reply to this message
 
Old 25-05-13, 08:09 PM   #4
davidireland
Guest
 
Posts: n/a
Default

Again, what engine?
  Reply With Quote Quick reply to this message
Old 25-05-13, 08:17 PM   #5
Member
 
Join Date: Oct 2012
Posts: 40
Default

And Dave the noise is a whirring and car never really felt like it wants to go my 406 8valve goes better .and the smoke reading at test 0.64 with old filter on and I drove back from test station first time no probs with (no unblock filter)but car never really got up to running temp on way back as it was late and no traffic hope this helps thanks bob
pullitt73 is offline   Reply With Quote Quick reply to this message
Old 25-05-13, 08:18 PM   #6
Member
 
Join Date: Oct 2012
Posts: 40
Default

Sorry 2.0hdi rhw
pullitt73 is offline   Reply With Quote Quick reply to this message
Old 25-05-13, 08:19 PM   #7
Member
 
Join Date: Oct 2012
Posts: 40
Default

It's a 04 plate
pullitt73 is offline   Reply With Quote Quick reply to this message
Old 25-05-13, 08:21 PM   #8
davidireland
Guest
 
Posts: n/a
Default

Do the turbo pipes expand when you rev the engine?
Its hard to tell from here if the turbo has failed. Take the car to your dealer or a good Peugeot specialist and give them a look at it.
  Reply With Quote Quick reply to this message
Old 26-05-13, 01:34 AM   #9
Member
 
Join Date: Oct 2012
Posts: 40
Default

Hi there all just got in from walking home from work.
The turbo has gone and I think it's snapped off on the exhaust side hence the whine / rattle. Got back from driving tonight/morning and started car looked at back to see if any smoke there was none so I gave it a little blip and still no smoke out of back turned round and the smoke was coming out of o/s/f and side so I looked and the gasket on the dpf is blowing as I'm now laying down looking at dpf I see I think is water so I give it a big rev blue smoke out of gasket area and so black stuff water and soot me thinks then I look a little hard at it an it's all gloopy blacky grey stuff its oil oh bugger new filter shot now so I will be in work later ripping it all apart and fitting my new turbo core nice bank hol eh and thanks davidireland for your input many thanks bob
pullitt73 is offline   Reply With Quote Quick reply to this message
Old 26-05-13, 07:11 AM   #10
chopper1192
Guest
 
Posts: n/a
Default

Slower than 8v 406... is that even possible?
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:31 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.