Power steering trouble - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > MPVs > 806/807
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-07-16, 05:48 PM   #1
Inactive User
 
Join Date: Jul 2015
Posts: 45
Default Power steering trouble

I all my s reg 806 is throwing its power steering fluid out the top of the reservoir it's a horrible burnt brown colour and stinks I presume the pump is knackered otherwise it would have lost its fluid ?? Any info would be lovely the car has also started making a horrible metal to metal noise after I Rev it
ddeano1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-07-16, 10:32 PM   #2
Senior Member
 
Join Date: Nov 2011
Posts: 192
Default

Sounds like you're having more than your fair share of problems at the moment. I think you need to get it looked at sooner rather than later.
citrail is offline   Reply With Quote Quick reply to this message
Old 11-07-16, 10:33 PM   #3
Inactive User
 
Join Date: Oct 2015
Location: Porthmadog, North West Wales
Posts: 29
Default

Take a look at the mesh screen filter that sits inside the p/s reservoir, it may be blocked. If it is, give it a good clean with carb/brake cleaner followed by compressed air on both sides, flush system , replace fluid. You say the car is making a noise, do you mean the engine.
Xudpug is offline   Reply With Quote Quick reply to this message
 
Old 11-07-16, 11:21 PM   #4
Inactive User
 
Join Date: Jul 2015
Posts: 45
Default

If I take that bit out and turn side to side with engine running it throws the fluid out when it reaches its lock , and I've since realised the noise isn't the power steering as I took belt off and ran the car , I think it's my water pump
ddeano1 is offline   Reply With Quote Quick reply to this message
Old 12-07-16, 08:31 AM   #5
Senior Member
 
Join Date: Nov 2011
Posts: 192
Default

Arh well, fairly easy fix then
citrail is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:29 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.