Help! P0340 No signal from Camshaft Sensor - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > MPVs > 806/807
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By Mav

Reply
 
LinkBack Thread Tools Display Modes
Old 01-01-12, 02:51 PM   #1
Mav
Inactive User
 
Join Date: Jan 2012
Location: Northern Ireland
Posts: 16
Exclamation Help! P0340 No signal from Camshaft Sensor

Hi

I recently rebuilt my 2.0 16v HDI engine after timing belt failure but now the car wont start.

See my post on the Eurovan Forum: Ulysse 2.0 16V JTD 2004 Engine repair project

I'm getting the P0340 fault from my PP2000 reader, Screenshots below.

I have replaced the Cam sensor but still get the same fault. screenshots show that there is an RPM reading so I can assume that the Crank sensor is ok and also that last screenshot shows that the Cam & Crank are synchronised.

I disconnected the cam sensor but still get that same fault code although now it is shown as an intermittent fault rather than a permanent one. Also the Cam & Crank do not show as synchronised which is as expected.

Has anyone got any suggestions before I do anything drastic?

I was confident that I set the timing correct. Is it possible for the crank to be 180 deg. out on these engines?

Cheers







Mav is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-01-12, 04:18 PM   #2
Mav
Inactive User
 
Join Date: Jan 2012
Location: Northern Ireland
Posts: 16
Default

Got it sorted.

Turned out that when setting the timing I forgot to release the three bolts on the cam pulley to ensure the correct belt tension so the belt was a couple of teeth out.

Thankfully it doesn't appear that any damage was done as a result as car started first time and seems to be running well.

No faults now shown when connected to PP2000.
bettyswollocks likes this.
Mav is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:41 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.