807 hdi 2.2 diesel non runner - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > MPVs > 806/807
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 30-12-17, 04:59 PM   #1
Junior Member
 
Join Date: Dec 2017
Posts: 2
Unhappy 807 hdi 2.2 diesel non runner

HELP ME PLEASE!!!!

brought an 807 and sent it away for mot came back and stopped working engine immobiliser fault coming up and airbag fault brake fault and tyre fault, now its completely dead wont start at all beeps like an alarm is going to go off been told to replace ecu or have it rebuilt......anyone know anything that could be causing it is it ecu? battery is 8 months old so i guess it cant be that?? any help or advuce would be reat
laurel17 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 30-12-17, 05:24 PM   #2
Senior Member
 
greegor's Avatar
 
Join Date: Sep 2013
Location: Hove East Sussex
Posts: 822
Default

First thing first you need a proper read of the ecu's and fault codes.
contact a member with planet, see link.
https://www.peugeotforums.com/forums/20307-post1.html
__________________
2008 feline 115 hdi. Life's a bitch so enjoy it!
greegor is offline   Reply With Quote Quick reply to this message
Old 30-12-17, 09:55 PM   #3
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,916
Default

It is NOT the ecu its never the ecu

It MIGHT be the BSI this is separate and lives under the dash drivers side A pillar but as above you need to get it read properly to find out the real issue.

Check ALL wiring at the battery this is a common problem area check ALL fuses

Do the beep test but sounds like it will fail that

has any messing with radios been done if so again check fuses remove any non standard radio/wiring
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:58 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.