807 2.2hdi P0245 fault code Please Help - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > MPVs > 806/807
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 31-05-10, 03:48 PM   #1
Inactive User
 
Join Date: May 2010
Posts: 11
Unhappy 807 2.2hdi P0245 fault code Please Help

Hi please can someone help, we have just purchased a 807 2.2 hdi, when we drive it the engine light comes on, and it goes into limp mode.

If we pull over turn off the car lock it then unlock it we have full power back but the light remains.
The fault code is

P0245 Intermittent fault. Turbo pressure, turbo pressure measured to high

What does this mean? is there a fix? do we need a new Turbo?

Sometimes if you turn the car off leave it over night then restart it in the morning then drive the light goes out, but then comes back on. We do not get anit pollution messages and the fluid has been re filled etc
merc85 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 31-05-10, 08:18 PM   #2
Inactive User
 
PureJoe's Avatar
 
Join Date: Feb 2010
Location: Near Watford
Posts: 535
Default

Sounds like a turbo solenoid valve - budget for about 150.
PureJoe is offline   Reply With Quote Quick reply to this message
Old 31-05-10, 09:56 PM   #3
Inactive User
 
Join Date: May 2010
Posts: 11
Smile

Thanks for the reply, joe, where is this valve? do you have a part number for it?
merc85 is offline   Reply With Quote Quick reply to this message
 
Old 31-05-10, 11:02 PM   #4
Inactive User
 
PureJoe's Avatar
 
Join Date: Feb 2010
Location: Near Watford
Posts: 535
Default

I'm dragging this info from memories of a mate's 406. While I'm about it, see pic. I think it's around number 7...(?) (If that's your set up.) Also check all the hoses, etc. for collapse, leaks, splits, or looseness.
Attached Thumbnails
turbo.jpg  
PureJoe is offline   Reply With Quote Quick reply to this message
Old 01-06-10, 11:31 PM   #5
Inactive User
 
Join Date: May 2010
Posts: 11
Default

thanks joe for the reply, have contacted peugeot, 95 +vat for part, book in at a specialist, for code read, he seems pritty sure it's a vac/pipe leak.

will keep everyone posted on outcome.
merc85 is offline   Reply With Quote Quick reply to this message
Old 10-06-10, 12:47 PM   #6
Inactive User
 
Join Date: May 2010
Posts: 11
Default smoke test

Hi Had the specialist do a smoke test, no evidence of a boost leak from the hoses/intercooler, they thought one of the 2 valves at the bottom of the scuttle panel where to blame so changed the faulty one.

Car seemed ok but again the light came on the following day have booked it in again with garage.

Any more ideas???
merc85 is offline   Reply With Quote Quick reply to this message
Old 10-06-10, 04:40 PM   #7
Inactive User
 
Join Date: Aug 2009
Location: ilkley,west yorkshire
Posts: 134
Send a message via MSN to toddy2
Default fault

hi,,,make sure the vacuum swirl capsule rod is intact and operating correctly.

toddy
toddy2 is offline   Reply With Quote Quick reply to this message
Old 11-06-10, 12:21 AM   #8
Inactive User
 
Join Date: May 2010
Posts: 11
Default light out

engine light now out, I took the out the Large actuator housing which conects to the intake manifold. one of the butterfly flaps was/is sticky.

I cleaned it out with brake cleaner then sprayd wd40 in it. dry'd it and re assembled, after to rev's the engine light went out. and has stayed out.

Hopefully this is the problem, if it stays out i will buy a new unit around 100.
thanks for everyones help.
merc85 is offline   Reply With Quote Quick reply to this message
Old 11-06-10, 02:17 PM   #9
Inactive User
 
Join Date: May 2010
Posts: 11
Default up date

Dam light back on after 2 miles, and in limp mode. got it home took the actuator off again and the bottom flap is sticky and as a lot of side to side movement.

But it all back together and the light has gone out???? this surely must be the problem?
merc85 is offline   Reply With Quote Quick reply to this message
Old 12-06-10, 06:30 PM   #10
Inactive User
 
Join Date: May 2010
Posts: 11
Default

Now replaced air doser/actuator/mixer and the light is still there?
merc85 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 10:27 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.