Peugeot Forums

Peugeot Forums (https://www.peugeotforums.com/forums/)
-   508 (2011-18) (https://www.peugeotforums.com/forums/508-2011-18-76/)
-   -   Cannot open drivers door from outside (https://www.peugeotforums.com/forums/508-2011-18-76/cannot-open-drivers-door-outside-338048/)

stayfrosty 26-05-19 06:35 AM

Cannot open drivers door from outside
 
HI

I recently bought a 508 sw 2012 with keyless entry, and I have problems with the handle on the drivers door, it is not possible to open it from the outside in the current state.

When you pull it, there's no resistance, so the door handle is "opened" but the door remains shut. Opening the door from the inside still works. In the beginning it could happen from time to time, but if you pushed the handle back and tried again a few times it started working, but now it seems permanent.

From what i read, some people have problem with the keyless sensor, but that doesn't seem to be any issue here, if i touch it it locks/unlocks as it should do.

Any one have an idea what the problem could be?

windy1603 26-05-19 08:15 AM

If the car is unlocked and the handle does not work it's a mechanical issue with the handle or lock such as a link rod disconnected.

Sent from my SM-G965F using Tapatalk

stayfrosty 26-05-19 04:56 PM

After being constantly not working, it magically started to work again after 50 km of driving. This feels very unreliable. Could it still be a mechanical issue, when it sometimes work and sometimes don't? I guess I should remove the door panel and investigate.

windy1603 26-05-19 06:25 PM

It could still be mechanical it maybe the the unlock motor/solenoid or the lock mechanism is just sticky you may be able to get away with squirting wd40 or similar into the lock mechanism via the catch cutout etc

Layer8 28-05-19 03:37 PM

Quote:

Originally Posted by stayfrosty (Post 2249482)
HI

I recently bought a 508 sw 2012 with keyless entry, and I have problems with the handle on the drivers door, it is not possible to open it from the outside in the current state.

When you pull it, there's no resistance, so the door handle is "opened" but the door remains shut. Opening the door from the inside still works. In the beginning it could happen from time to time, but if you pushed the handle back and tried again a few times it started working, but now it seems permanent.

From what i read, some people have problem with the keyless sensor, but that doesn't seem to be any issue here, if i touch it it locks/unlocks as it should do.

Any one have an idea what the problem could be?

I have the exact same issue on the offside front door. Only manifested itself recently.
I sprayed some WD40 into the doorlock as I thought it was as windy suggested, but no avail. Absolutely no resistance when teh door leaver is pulled and the unlocking sensor works perfectly, every time. Opening from the inside works, every time. I will see if I can get more WD 40 into the door lock and see if this cures it.

Layer8 28-05-19 03:41 PM

Quote:

Originally Posted by stayfrosty (Post 2249570)
After being constantly not working, it magically started to work again after 50 km of driving. This feels very unreliable. Could it still be a mechanical issue, when it sometimes work and sometimes don't? I guess I should remove the door panel and investigate.

It will happen again, as this happened the passenger door on mine. Didn't work, then worked for a while then stopped completely after a while.
Currently not working at all.
The issue will more than likely deteriorate, unfortunately. Keep us posted here, I will do the same with any developments.

stayfrosty 11-06-19 06:27 PM

Quote:

Originally Posted by Layer8 (Post 2250050)
It will happen again, as this happened the passenger door on mine. Didn't work, then worked for a while then stopped completely after a while.
Currently not working at all.
The issue will more than likely deteriorate, unfortunately. Keep us posted here, I will do the same with any developments.

I managed to "fix" mine, or at least it has been constantly working for a few days now.

I followed the youtube video on how to remove the handle without the need to remove the door panel ( i couldnt post links, youtube id is 6LsUHkf2Xq8)

Inside the lock-hole on the left side (towards the handle), there is a black "latch" (sorry, english isnt my mother tongue so maybe there's a better word) that the handle pulls when you pull the handle, and when you release the handle it is supposed to push back. Mine got stuck in the "pulled" position even when the handle was released, so i sprayed it with WD-40 where there looked to be a joint (hard to see in there) and after that it has worked.
I "massaged" it a bit to loosen it up by pulling and pushing manually until it pushed back.

I guess a more sticky lubricant than WD-40 could be a good idea.

Layer8 12-06-19 09:55 AM

Quote:

Originally Posted by stayfrosty (Post 2252950)
I managed to "fix" mine, or at least it has been constantly working for a few days now.

I followed the youtube video on how to remove the handle without the need to remove the door panel ( i couldnt post links, youtube id is 6LsUHkf2Xq8)

Inside the lock-hole on the left side (towards the handle), there is a black "latch" (sorry, english isnt my mother tongue so maybe there's a better word) that the handle pulls when you pull the handle, and when you release the handle it is supposed to push back. Mine got stuck in the "pulled" position even when the handle was released, so i sprayed it with WD-40 where there looked to be a joint (hard to see in there) and after that it has worked.
I "massaged" it a bit to loosen it up by pulling and pushing manually until it pushed back.

I guess a more sticky lubricant than WD-40 could be a good idea.

Well done. I will try this at the weekend. Thanks for the update.


All times are GMT. The time now is 11:21 AM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.