Water in diesel fuel filter - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 21-11-15, 10:15 AM   #1
Member
 
Join Date: Jul 2015
Posts: 40
Default Water in diesel fuel filter

Hi all

Yesterday when I went to start my car it started for about a second and died flagging this error on the dash. I left it 5 and it started again and ran fine. I know where the fuel filter is located and know I need to drain the water. My question is after I have done this do I need to prime the system again using the primer bulb or? Also I'm not sure when the filter was last changed so should I just do that whilst at it? Would a halford one be OK? Or just stay clear? Do I have to change the rubber seal also or can it be used again?

It has done this once or twice before and shows a little jar like thing half filled on the display.

Thanks for any help

Thomas

Sent from my MotoE2(4G-LTE) using Tapatalk
tommywasash is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 21-11-15, 04:51 PM   #2
Senior Member
 
mooi1uk's Avatar
 
Join Date: Jan 2013
Location: Cornwall UK
Posts: 1,758
Default

You shouldn't need to prime it after draining the water but you would need to if you change the filter. New seals should come with the new filter. A Halford's one will be fine, I've always found their parts are good.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1.6THP GTLine EAT6 Leather+Grip+ACC+O&G+Smart Boot
mooi1uk is offline   Reply With Quote Quick reply to this message
Old 21-11-15, 05:43 PM   #3
Member
 
Join Date: Jul 2015
Posts: 40
Default

Got sorted and all earlier whilst I still had light on my side. Drained only a small bubble o water in bottom of container I used. Car springs to life now tho. Good job all round.

Thanks. I will go pick up a new filter tomorrow and fit, will know its done then.

Sent from my MotoE2(4G-LTE) using Tapatalk
tommywasash is offline   Reply With Quote Quick reply to this message
 
Old 29-06-18, 08:28 PM   #4
Junior Member
 
Join Date: Jan 2018
Posts: 4
Default

Error never showed up again?
tommar is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 05:33 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.