speed control not working - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 19-10-13, 02:58 PM   #1
Inactive User
 
Join Date: Sep 2013
Location: Stockton on tees
Posts: 20
Default speed control not working

Hi, problem with my speed control, checked the handbook for correct method of operation and up to actually setting the speed it appears to be working correctly, when i reach say 70mph, i switch to set the speed, this is displayed on my dash as 3 blank lines, it does not make any difference if then i press button 2or3 the 3 lines are still there and no speed is displayed or set, if i press the end button, display says cannot activate speed control as no speed set, should switch 2 or 3 be positive as i cannot feel even the smallest resistance,click or otherwise, may be the micro switches/stalk are u/s, any suggestions please.
geoff40752 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 19-10-13, 05:19 PM   #2
Inactive User
 
Join Date: Sep 2013
Posts: 34
Default

get to say 60 and press top button to set speed,,current speed is displayed on screen you then can increase or decrease by top(more) or bottom(less) by pressing in increments,button on end releases cruize or brings it back on when you want, or ofcourse by braking releases cruize hope this helps
bobbyg is offline   Reply With Quote Quick reply to this message
Old 19-10-13, 07:35 PM   #3
Senior Member
 
storeman's Avatar
 
Join Date: Jan 2013
Location: Oldham, UK
Posts: 5,906
Default

More than likely a faulty brake switch stopping the cruise working. Retrofitted cruise to both of my 307's and had to replace the brake switch on both of them. The set+ & set- switches aren't very positive. I don't feel or hear the switches at all but they do work.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
storeman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:01 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.