Servo pump - Steering rack problem - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By rwb

Reply
 
LinkBack Thread Tools Display Modes
Old 21-12-18, 08:24 AM   #1
Junior Member
 
Join Date: Dec 2017
Location: Tuzla- Bosnia
Posts: 3
Default Servo pump - Steering rack problem

Hi guys , I have problem with electronic servo pump, it is loosing oil on cap, and boiling inside , very common problem for this car, I wanted to change servo pump with another, but today I realised that it starts to boil oil only when I turn steering wheel on max left or max right side, then it starts to make buzzz sound on servo pump and oil starts to make foam inside.

Is it possible to be faulty steering rack , or just servo pump, I was thinking that steering rack in that position have some air coming inside and making foam in servo pump.

I would appreciate if you could give me some advices.


Thanks
__________________
Peugeot 407 SW 2.0 HDI 2005
samsung55 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 23-12-18, 12:07 PM   #2
rwb
Senior Member
 
rwb's Avatar
 
Join Date: Jun 2012
Location: Telford
Posts: 996
Send a message via Skype™ to rwb
Default

Yes, it is a known problem on earlier cars that air gets into the power steering fluid and causes it to froth up and spill. You may also experience juddering when steering quickly.

Peugeot fixed this (2006 IIRC) by redesigning the high pressure pipe.

The usual suggestion for trying to get rid of the air is to over-fill the reservoir and work the steering from lock to lock.

For the overflowing: get a cheap yellow carwash sponge, poke a hole in it, and fit it round the filler nect to catch the spills.
trem1 likes this.
__________________
407 2.2 HDi & CitroŽn C6
I'm on the
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
rwb is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:48 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.