Real bad fuel economy 2.0 hdi - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-01-16, 07:39 PM   #1
Inactive User
 
Join Date: Dec 2015
Posts: 38
Default Real bad fuel economy 2.0 hdi

15 -20 mpg around town . easy driving isnt very good from what i hear . even on motor way i struggle to get 30. Low on funda at min so cheap fixes hopefully. ??
Whizzer is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-01-16, 08:18 PM   #2
Moderator
 
trem1's Avatar
 
Join Date: Jan 2010
Location: south shields,tyneside
Posts: 5,000
Default

You just got the car or had it awhile ?? Either way air filter is probably first thing I'd check.

Sent from my K013 using Tapatalk
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 Iron Grey 136bhp 2.0 hdi SE .........Written off
2006 Icelandic Grey 136bhp 2.0HDI SE......Written off
2006 Silver 136bhp 2.0hdi SE......Current car
Join us on FB "Peugeot 407 uk"
trem1 is online now   Reply With Quote Quick reply to this message
Old 10-01-16, 08:29 PM   #3
Inactive User
 
Join Date: Dec 2015
Posts: 38
Default

Had it a few months . gradually getting worse. Took out air filter to see if it helped . witch has not
Whizzer is offline   Reply With Quote Quick reply to this message
 
Old 10-01-16, 08:34 PM   #4
Moderator
 
trem1's Avatar
 
Join Date: Jan 2010
Location: south shields,tyneside
Posts: 5,000
Default

Fuel filter is next then.

Sent from my K013 using Tapatalk
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 Iron Grey 136bhp 2.0 hdi SE .........Written off
2006 Icelandic Grey 136bhp 2.0HDI SE......Written off
2006 Silver 136bhp 2.0hdi SE......Current car
Join us on FB "Peugeot 407 uk"
trem1 is online now   Reply With Quote Quick reply to this message
Old 10-01-16, 08:36 PM   #5
Inactive User
 
Join Date: Dec 2015
Posts: 38
Default

Yea next on list . :relaxed:
Whizzer is offline   Reply With Quote Quick reply to this message
Old 11-01-16, 05:38 AM   #6
Senior Member
 
B1ack__Mi16's Avatar
 
Join Date: May 2012
Location: Trondheim, Norway
Posts: 1,073
Default

Would guess it's got a heavily blocked DPF.
Check your oil-sump if there is eccessive amounts of oil in there. If that is the case, car fails to regenerate and clear out the filter for some reason, but it continues trying injecting extra diesel. Hence oil-sump fills up with diesel.

Not saying it is the case, but I had it like this on mine, and it had really bad fuel economy. However not one single "check engine" light even in this condiction.
__________________
5008
407 2.0HDi
405 T16/2.1TD
205 GTi 2.3/1.9
B1ack__Mi16 is offline   Reply With Quote Quick reply to this message
Old 11-01-16, 07:44 AM   #7
Inactive User
 
Join Date: Dec 2015
Posts: 38
Default

God I would if I could get under the thing its to low forbmy stubby jack .
Whizzer is offline   Reply With Quote Quick reply to this message
Old 11-01-16, 07:54 AM   #8
Senior Member
 
B1ack__Mi16's Avatar
 
Join Date: May 2012
Location: Trondheim, Norway
Posts: 1,073
Default

It would suffice just to open the hood and take a look at the oil-stick if it's over the maximum level
__________________
5008
407 2.0HDi
405 T16/2.1TD
205 GTi 2.3/1.9
B1ack__Mi16 is offline   Reply With Quote Quick reply to this message
Old 11-01-16, 08:19 AM   #9
Senior Member
 
Join Date: Jul 2014
Location: Jersey CI
Posts: 2,398
Default

Quote:
Originally Posted by Whizzer View Post
God I would if I could get under the thing its to low forbmy stubby jack .
Don't ever get under a car supported by a jack. Axle stand every time!
IanML is offline   Reply With Quote Quick reply to this message
Old 11-01-16, 08:26 AM   #10
Inactive User
 
Join Date: Dec 2015
Posts: 38
Default

Oil level is grand . she does not use much
Whizzer is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:30 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.