probs with ESP, oil preasure, depolution (electronic) - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 29-09-11, 10:37 PM   #1
Inactive User
 
Join Date: Sep 2011
Posts: 27
Default probs with ESP, oil preasure, depolution (electronic)

Hello
i am new here
couple days ago, i bought peugeot 407 2.0 Hdi 136 hp with 139.000km on it! evrything was great until yesrday... i was driving home, and than sudendly i got 3 warnings at once and car turn off by it self:

1. ESP doesnt work
2. motoro oil preasure is very low
3. depolution fault

i restart the engine, and evrything was perfect! no errors... 3 hours later, same problem... again restart engine, problem disapired later that day... same scenario happend one more time!
today i drove car at service, they hooked up in PC and they find couple of errors but all of them were irelevant and was deleted!

in 2 days, i am going to vaccation, and have about 1000 km in front of me...

does anyone know what could cause these erorrs? Mechanics have no idea
Mirko SRB is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 30-09-11, 06:51 AM   #2
Senior Member
 
bettyswollocks's Avatar
 
Join Date: Mar 2009
Location: Northern Ireland
Posts: 9,737
Default

Get a service done and use good oil, if you can get a diagnostic done to check the % load of your FAP filter , you could also replace your oil pressure sensor (12) to rule it out as causing faults.
bettyswollocks is offline   Reply With Quote Quick reply to this message
Old 30-09-11, 08:59 AM   #3
Inactive User
 
Join Date: Sep 2011
Posts: 27
Default

today i will change oil and filter, rear brakes... i hope that erorr wont came up anymore
why i cant post to introduction section of this forum?
Mirko SRB is offline   Reply With Quote Quick reply to this message
 
Old 05-10-11, 10:45 PM   #4
Inactive User
 
Join Date: Sep 2011
Posts: 27
Default

i changed brakes, oil and filter.. and on my way i had 3 times car switched off in highway, and there were same erorr!
car was also on PC pluged in, but there were no erorr...
when i restart engine... no erorr



Uploaded with ImageShack.us
Mirko SRB is offline   Reply With Quote Quick reply to this message
Old 24-03-13, 10:19 AM   #5
Inactive User
 
Join Date: Sep 2011
Posts: 27
Default

Hello
I still did not solove problem with errors
does anyone have any ideas?
I am driving not reliable car i cant go on vaccation or anywhere, only short routes
Mirko SRB is offline   Reply With Quote Quick reply to this message
Old 24-03-13, 10:39 AM   #6
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,018
Default

I had one doing this and i replaced the fusebox under bonnet seemed to cure it have not seen him in 4 months
reliable406 is offline   Reply With Quote Quick reply to this message
Old 24-03-13, 10:47 AM   #7
Inactive User
 
Join Date: Mar 2013
Location: Hampshire, right by the sea.
Posts: 127
Default

Hi there

When does the oil pressure warning occur?

Cold start?
Warm start?
Highway driving?
At idle?

It could well be the oil pressure switch? As another op said, cheap to replace so wont harm.

As for the other faults I can't help. Sorry!

I am having the same issues. Oil pressure warning (hot start), and I've just started to get ESP/ ABS fault. No plug in diag yet. I need to measure ABS sensors as it seems to be a common fail.

Unfortunately French cars have a reputation about the electronic parts!!
savs is offline   Reply With Quote Quick reply to this message
Old 24-03-13, 10:57 AM   #8
Inactive User
 
Join Date: Sep 2011
Posts: 27
Default

its happening all time
couple times its happend on highway,
2-3 times happend in the morning while i driving on job 1-2 km from my house (it was city driving)
and the worst thing is sometimes i get error every day, and sometimes i dont see error 6-8 month :/

does your car turns off after erorrs came up?
Mirko SRB is offline   Reply With Quote Quick reply to this message
Old 24-03-13, 10:58 AM   #9
davidireland
Guest
 
Posts: n/a
Default

Sounds like a fusebox problem alright as above.
  Reply With Quote Quick reply to this message
Old 24-03-13, 11:10 AM   #10
Inactive User
 
Join Date: Sep 2011
Posts: 27
Default

how much cost fuse box change? since services are unable to find solution for my problems, should i reqest changing fuse box?
Mirko SRB is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 10:53 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.