Peugeot 407 2.0 hdi 2005. engine cooling fan - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-06-18, 07:03 AM   #1
Junior Member
 
Join Date: Jun 2018
Posts: 2
Default Peugeot 407 2.0 hdi 2005. engine cooling fan

Hi. New to forum & got a problem. My engine cooling fan is not working. Only found out when i was towing my caravan all was fine until i got the stop sign on dash & temp symbol. Stopped car straight away and checked all fuses. All fuses in glove box & under bonnet checked out fine. Dont gave pp 2000. Anybody near me in ilkeston Derbyshire who can plug car in & tell me what is wrong. Willing to pay in beer LOL. Cheers eddy
Eddy4973 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-06-18, 04:01 PM   #2
Senior Member
 
Join Date: Aug 2012
Location: Margate UK
Posts: 1,063
Default

Didn't the temperature gauge tell you something was amiss?.
Does the fan come on with the a/c?, (it should).
I suspect the relay for the fan isn't working, plug in diagnostics might not detect that.

Roger.
__________________
Keeping clunkers out of junkyards.
rustyroger is offline   Reply With Quote Quick reply to this message
Old 12-06-18, 04:33 PM   #3
Member
 
Join Date: Apr 2013
Location: London North
Posts: 67
Default

That's true. diagnostics might or might not help in finding the underlying issue, although with the diag you can force activate the fan to see if it spins or not.

With the assumption that temperature sensor works properly and the fan fuse(s) are fine, the problem in most cases is in the fan relay that can be "stuck" in off or on position. The remedy is usualy a dissasembly of the relay and cleaning of the circuit board and contacts or a new relay. Before that check the fan connecting it directly to 12V from a suitable source.
Westerner is offline   Reply With Quote Quick reply to this message
 
Old 12-06-18, 06:52 PM   #4
Junior Member
 
Join Date: Jun 2018
Posts: 2
Default

Hi. Thanks for the replies. The temp gauge was hovering between 90-95 before it said stop. When i had stopped i left it a while to cool but on restarting fan was not on. Driving normally aircon is ok until car gets warm or i get stuck in traffic then aircon becomes warmer. Thanks eddy
Eddy4973 is offline   Reply With Quote Quick reply to this message
Old 12-06-18, 08:11 PM   #5
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,018
Default

Fans on these have a control unit on the fan housing this unit fails and if the aircon is on the fan should be running not just when hot
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:29 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.