P2562 - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By Flipflop

Reply
 
LinkBack Thread Tools Display Modes
Old 10-06-19, 08:46 PM   #1
Junior Member
 
Join Date: May 2019
Posts: 6
Default P2562

Wondering if any of this makes any sense to someone
Attached Thumbnails
20190610_202230_1560199541115.jpg  
Flipflop is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-06-19, 11:35 AM   #2
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,573
Default

What are the live MAF readings?
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 11-06-19, 12:08 PM   #3
Junior Member
 
Join Date: May 2019
Posts: 6
Default

Hopefully this is what you mean
Attached Thumbnails
20190611_130237_1560254918748.jpg  
Flipflop is offline   Reply With Quote Quick reply to this message
 
Old 12-06-19, 11:23 AM   #4
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,573
Default

Yep. Its odd how both screens are showing different air temperature readings at the MAF.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 12-06-19, 09:26 PM   #5
Senior Member
 
Join Date: Jul 2017
Location: Glenrothes
Posts: 718
Default

Quote:
Originally Posted by Gibbo View Post
Yep. Its odd how both screens are showing different air temperature readings at the MAF.
Yep the -50 in the first pic seems wrong,also in the first pic the turbo pressure measured and turbo pressure reference both at 4mbars seems wrong to me too especially as the engine was revving at 2600rpm at the time the fault code was registered...

A vacuum problem maybe or turbo position repeat sensor,although the MAF or the wiring to it must be suspect first to give a reading of -50c
__________________
Peugeot 307xsi 2.0hdi 110bhp 2004.
terry57 is offline   Reply With Quote Quick reply to this message
Old 12-06-19, 09:28 PM   #6
Junior Member
 
Join Date: May 2019
Posts: 6
Default

I've checked all vac pipes and solenoids. All were fine. Have also change position sensor
terry57 likes this.
Flipflop is offline   Reply With Quote Quick reply to this message
Old 12-06-19, 09:37 PM   #7
Senior Member
 
Join Date: Jul 2017
Location: Glenrothes
Posts: 718
Default

my next try then if you have already done all that would be disconnect the MAF and see if it makes any difference,if it doesnt then i would suspect either the MAF itself or the wiring to it
__________________
Peugeot 307xsi 2.0hdi 110bhp 2004.
terry57 is offline   Reply With Quote Quick reply to this message
Old 12-06-19, 09:49 PM   #8
Junior Member
 
Join Date: May 2019
Posts: 6
Default

I'll have a look at that. I did try putting a vacuum directly on the turbo actuator to see if there was any movement in the arm but there was next to none
Flipflop is offline   Reply With Quote Quick reply to this message
Old 14-06-19, 01:57 PM   #9
Junior Member
 
Join Date: Jan 2018
Posts: 2
Default

I replaced turbo because of same error, first i replace all solenoid valves, all vacuum lines, turbo position sensor and vacuum actuator but error still was showing. After I replace complete turbo now is ok


Sent from my iPhone using Tapatalk
Boko is offline   Reply With Quote Quick reply to this message
Old 17-06-19, 09:51 PM   #10
Junior Member
 
Join Date: Jul 2018
Posts: 25
Default

Before you do anything expensive simply disconnect the MAF. If it returns to running normal the it's the MAF that is goosed. If it still runs crap, it's not the MAF

Sent from my SM-G960F using Tapatalk
rodduz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:34 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.