My 407 Diesel dies at just over 3000 Revs - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 17-07-11, 06:18 PM   #1
Inactive User
 
Join Date: Jul 2011
Posts: 2
Angry My 407 Diesel dies at just over 3000 Revs

Hi can anyone give me a clue where to start? My 54 plate 407 2ltr diesel auto
refuses to advance above 3000 revs, feels as if the fuel is being cut off. I have changed all the filters but has made no difference. The car does a max of 80 mph but I have to build the revs up slowly to get there. up to 3000 revs the car performs as it should.
Thanks in advance, Barcode47
Barcode47 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 17-07-11, 06:22 PM   #2
jmkent
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Barcode47 View Post
The car does a max of 80 mph
Thats all you should need
  Reply With Quote Quick reply to this message
Old 17-07-11, 06:23 PM   #3
Senior Member
 
bettyswollocks's Avatar
 
Join Date: Mar 2009
Location: Northern Ireland
Posts: 9,737
Default

Limpmode , you need Diagnostics done.
bettyswollocks is offline   Reply With Quote Quick reply to this message
 
Old 17-07-11, 07:04 PM   #4
Inactive User
 
bazzer's Avatar
 
Join Date: Jul 2010
Posts: 30
Default speed

hi there
this may not be of any help to you ,but i will tell you .
i got my 407 and could not get it over 70 mph . until a mechanic at a garage told me the problem ? the previous owner had set the cruise control to this speed and unknown to me had been left on . that was the problem with me so i am just giving you something to check ?
bazzer is offline   Reply With Quote Quick reply to this message
Old 17-07-11, 07:07 PM   #5
Senior Member
 
bettyswollocks's Avatar
 
Join Date: Mar 2009
Location: Northern Ireland
Posts: 9,737
Default

Quote:
Originally Posted by bazzer View Post
hi there
this may not be of any help to you ,but i will tell you .
i got my 407 and could not get it over 70 mph . until a mechanic at a garage told me the problem ? the previous owner had set the cruise control to this speed and unknown to me had been left on . that was the problem with me so i am just giving you something to check ?
Mines set at 100mph , but his problem is that its restricted rev of 3000rpm, even with limiter set at 60mph it would still rev out.
bettyswollocks is offline   Reply With Quote Quick reply to this message
Old 17-07-11, 07:09 PM   #6
davidireland
Guest
 
Posts: n/a
Default

Get a diagnostic check done. Post up faults.
  Reply With Quote Quick reply to this message
Old 17-07-11, 07:09 PM   #7
Senior Member
 
bettyswollocks's Avatar
 
Join Date: Mar 2009
Location: Northern Ireland
Posts: 9,737
Default

Quote:
Originally Posted by bettyswollocks View Post
Limpmode , you need Diagnostics done.
Quote:
Originally Posted by davidireland View Post
Get a diagnostic check done. Post up faults.
If we had a 1 everytime
bettyswollocks is offline   Reply With Quote Quick reply to this message
Old 17-07-11, 07:14 PM   #8
davidireland
Guest
 
Posts: n/a
Default

I need to program a particular button on my keyboard that will type that each time!
  Reply With Quote Quick reply to this message
Old 17-07-11, 08:11 PM   #9
jmkent
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by bazzer View Post
hi there
this may not be of any help to you ,but i will tell you .
i got my 407 and could not get it over 70 mph . until a mechanic at a garage told me the problem ? the previous owner had set the cruise control to this speed and unknown to me had been left on . that was the problem with me so i am just giving you something to check ?
That shouldn't make any difference as it is reset/switched to standby each time the ignition is switched of, even if the knob is rotated to still be on it won't be effective
  Reply With Quote Quick reply to this message
Old 17-07-11, 09:46 PM   #10
Inactive User
 
Join Date: May 2011
Location: Crawley
Posts: 552
Default

Quote:
Originally Posted by jmkent View Post
That shouldn't make any difference as it is reset/switched to standby each time the ignition is switched of, even if the knob is rotated to still be on it won't be effective
Indeed, mine CC is always on, but is set to -- until I dial in a speed.

My benchmark for performance issues on my car was whether it would do 115 or not, lol
__________________
407 1.6HDI SE (De-Cat & FAP)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
philkerman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:52 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.