Loss of power - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 23-02-13, 08:43 AM   #1
mdp
Inactive User
 
Join Date: Feb 2013
Posts: 3
Default Loss of power

Hi there,
I was hoping someone could help, I drive a 407 1.6 hdi 05 and last week the faulty depollution system warning came on. I didn't have chance to take it to the garage then last night on my was home from work I lost power when going up a hill and when I put the accelerator down there is a horrible noise and no power, I struggled to get to 30mph.
Does anyone have any ideas about what this is?
Thanks for your help
Mike
mdp is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 23-02-13, 08:50 AM   #2
Inactive User
 
Join Date: Aug 2011
Location: sittingbourne kent
Posts: 183
Default

You need to get a reputable garage/mechanic to look at and scan the vehicle as there could be 1 of a multitude of causes for this type of problem, If you can get the fault codes it will make life easier for forum members to offer advice. If the "horrible noise" was like running it without the air box on it could be one of the turbo hoses but as I mentioned there realy is not enough information to make any reliable diagnosis.
__________________
VAG CIT PUG REN HONDA FORD VAUX MaxiDas DS708

Last edited by richiepearce; 23-02-13 at 08:52 AM.
richiepearce is offline   Reply With Quote Quick reply to this message
Old 23-02-13, 08:35 PM   #3
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,626
Default

https://www.peugeotforums.com/forums/...gnostic-28190/
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
 
Old 25-02-13, 05:53 PM   #4
mdp
Inactive User
 
Join Date: Feb 2013
Posts: 3
Default Cost!

Hi and thanks for your help.

So I took the car to a garage and was basically told the turbo had burnt out and had got clogged up with some soot from the oil. The garage said I needed to following work doing -

New turbo
New fitting Kit
New Oil & Filter kit
New Air Filter
Flushing the system out

They have quoted me 1100 including labour, does this sound about right or expensive for the job?

Cheers
mdp is offline   Reply With Quote Quick reply to this message
Old 25-02-13, 06:49 PM   #5
davidireland
Guest
 
Posts: n/a
Default Re: Loss of power

Sounds dead on. What was your service history like.
Bare in mind this engine is probably rubbish at this stage if the turbo has failed. They fail for a reason. No 1 being poor servicing and or poor quality/incorrect spec oil.
Expect a second failure also if the turbo fitting procedure is not adhered to.

Sent from my GT-S5690
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 05:32 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.