Engine Problem - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 15-02-19, 09:59 AM   #1
Junior Member
 
Join Date: Nov 2018
Posts: 22
Default Engine Problem

I am having issues with my 2008 407 Coupe 2.0 HDi RHR. Leaving it idling for 30 seconds or so, cold or warm the engine will misfire / vibrate at 1300 rpm then rev up normally. If constantly rev it from idle it revs up fine.

When driving in 3rd gear, 4th gear, 5th gear and 6th gear at 1200 rpm till 2000 rpm I feel the engine vibrating or kicking.

In the morning, cold start, it cranks over for a couple of times then fires up.

I have taken the injectors to a specialist be tested and cleaned. Injectors are all good.

I scanned it for faults and none are found. No warnings or lights are flashing either.

Did anyone have this similar problem or does anyone know the route to solve this problem which I am experiencing?

Thanks for your time and help.
davscer is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 15-02-19, 11:05 AM   #2
Senior Member
 
Join Date: Dec 2016
Posts: 656
Default

Leave the car overnight as you do, in the morning before starting the car, open the bonnet and there's a little hand fuel pump going into the fuel housing, pump it up so it's hard and see if it still has the same issues
Gibbo likes this.
BiGK is offline   Reply With Quote Quick reply to this message
Old 15-02-19, 12:02 PM   #3
Junior Member
 
Join Date: Nov 2018
Posts: 22
Default

Thanks for your reply BiGK.

I will squeeze the fuel priming bulb after work (after 9 hours) and I will get back to you.

If the bulb is squeezes, this means its loosing fuel from the fuel pump?
davscer is offline   Reply With Quote Quick reply to this message
 
Old 15-02-19, 07:23 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,897
Default

No it does not mean the fuel pump is loosing fuel it means there is an air leak INTO the system normally a bad pipe joint somewhere the pumps are generally pretty reliable.

Your initial description would have me checking the EGR valve and pipework.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 16-02-19, 06:13 AM   #5
Junior Member
 
Join Date: Nov 2018
Posts: 22
Default

Morning, so I squeezed the fuel priming bulb and had to squeeze it one and half times to harden. Fired up normally...

It still vibrated and misfired at 1300 rpm. I felt the engine being more responsive... dont know if its just me.

Shall I clean or replace the EGR and which pipework should I check?

Thanks all for your help and time.

Last edited by davscer; 16-02-19 at 06:19 AM.
davscer is offline   Reply With Quote Quick reply to this message
Old 16-02-19, 11:41 AM   #6
Senior Member
 
Join Date: Dec 2016
Posts: 656
Default

It was a long shot... but it's a free check essentially. As said, it could be the EGR valve but I would also have a peek at the intake valve (diverter between turbo / intercooler & intake. )

That's the problem with these random faults.... you really need the car with you, shove it up on Peugeot Planet and go through the live data and see what values are out of spec. Could be as simple as a temperature sensor somewhere. If it was the main fuel pump, you would notice it at more than just 1300rpm.

Also check your engine mounts.... resonant frequencies can do all sorts
BiGK is offline   Reply With Quote Quick reply to this message
Old 16-02-19, 11:54 AM   #7
rwb
Senior Member
 
rwb's Avatar
 
Join Date: Jun 2012
Location: Telford
Posts: 996
Send a message via Skype™ to rwb
Default

I was just thinking engine mounts.

Grab the top of the rocker cover and use all your weight to try to rock the engine backwards and forwards. If it moves then the mounts need replacing.

+1 for EGR because it's open when the engine is cold. To confirm/eliminage: just blank it.
__________________
407 2.2 HDi & CitroŽn C6
I'm on the
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
rwb is offline   Reply With Quote Quick reply to this message
Old 18-02-19, 07:40 AM   #8
Junior Member
 
Join Date: Nov 2018
Posts: 22
Default

Thanks all for your help.

I can put my mind at rest that the fuel pump is doing its job well.

So, cleaning EGR for the misfire at 1300 rpm, the engine mounts for the vibrates and the fuel pipe work for the hard starting.

I guess that the gearbox mount is at fault here?
davscer is offline   Reply With Quote Quick reply to this message
Old 18-02-19, 06:08 PM   #9
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

More likely the lower engine stabiliser under the car on the driver's side.
WillNZ is offline   Reply With Quote Quick reply to this message
Old 23-02-19, 07:58 AM   #10
Junior Member
 
Join Date: Nov 2018
Posts: 22
Default

Took the Pug to my mechanic (ex Peugeot Mechanic) on Thursday.

Got the car back yesterday. The EGR was full of carbon and wasnt closing well, so it was cleaned and wow what a difference. Its not the same car anymore. More responsive, no smoke and no vibrations! I just hope it remains like this!

When I asked him if he found any fuel leaks and none were found. It still misfires (shakes) from idle to 1300 rpm when left at idle for some 40 seconds...

When i started it this morning it took sometime to fire up too.

Two rubber bushes were changed too as they were completely shot.

If this misfire (shake) isnt cured, I will take it to the main dealer.
davscer is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine cooling fan stays on after engine turned off Johnnys149 407 4 25-01-12 03:18 PM
Engine swap, blanking bolt at rear of engine Chris_300 306 1 21-04-10 09:03 AM
hi guys. is the 307 cc 180bhp engine the same as the 206 gti 180 engine????????? willgti180 206 3 04-04-10 10:00 AM
406 HDi 110 engine swap with 307 Engine gurugomf 406 0 10-02-10 03:24 PM
406 HDI Engine To replace Expert HDI engine mitch3893 Expert 1 06-05-08 10:42 PM


All times are GMT. The time now is 01:23 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.