Driver side window switch - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-03-13, 11:52 AM   #1
Junior Member
 
KAG888's Avatar
 
Join Date: Mar 2013
Location: Swindon
Posts: 7
Default Driver side window switch

My 407sw driver side switch consul does not work any of the door windows, it does allow alteration of the wing mirrors. All the individual door window switches work except the driver's door!
If I pull upward on the passenger switch on the consul there is a movement.
My question is how can I test if it is the switch consule or a relay on the circuit someplace.
KAG888 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-03-13, 01:52 PM   #2
Inactive User
 
Join Date: Dec 2012
Location: Worcester, UK
Posts: 343
Default

Quote:
Originally Posted by KAG888 View Post
My 407sw driver side switch consul does not work any of the door windows, it does allow alteration of the wing mirrors. All the individual door window switches work except the driver's door!
If I pull upward on the passenger switch on the consul there is a movement.
My question is how can I test if it is the switch consule or a relay on the circuit someplace.
You can firstly remove the switch and give it a clean with compressed air or brushing the crap out from between the contacts. This solves alot of issues in the first instance.
__________________
[I]Peugeot 307 SW SE (2003) 2.0HDI 110 - RT3 & Cruise[/I]
matt002 is offline   Reply With Quote Quick reply to this message
Old 03-03-13, 01:58 PM   #3
Junior Member
 
KAG888's Avatar
 
Join Date: Mar 2013
Location: Swindon
Posts: 7
Smile

Many thanks for that. Simple, I will give it a go
KAG888 is offline   Reply With Quote Quick reply to this message
 
Old 08-03-13, 02:11 PM   #4
Junior Member
 
KAG888's Avatar
 
Join Date: Mar 2013
Location: Swindon
Posts: 7
Default

Turned out the whole unit was u/s. Just fitted a new one (from Ebay) and all switches work their respective window.
Thanks for your contribution.
KAG888 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 05:03 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.