De pollution system faulty P0095 - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 07-02-13, 12:18 AM   #1
Inactive User
 
Join Date: Dec 2012
Location: Castlederg
Posts: 47
Default De pollution system faulty P0095

My Engine light came on, on my 2005, 407HDi 136, as i was casually driving along, around a month ago.
Nothing changed with the car, going as good as ever, no bother with the engine, start up etc.

Got it on the diagnostics anyway, one similar to peugeot planet... it gave the fault code - 'p0095 - air temp signal after exchange coherence fault', something like that.

Is there a sensor that needs replaced just?

As i say the car is running 100%,
Any ideas of what i should do?



Replies appreciated... cheers
SeanMc7877 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-02-13, 07:17 AM   #2
Inactive User
 
Join Date: Aug 2011
Location: Dorset
Posts: 677
Default

Mine did the same just before Christmas !
New sensor from GSF 15, fitted it and problem sorted
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
407 mad is offline   Reply With Quote Quick reply to this message
Old 08-02-13, 01:37 PM   #3
Inactive User
 
Join Date: Dec 2012
Location: Castlederg
Posts: 47
Default

Wheres abouts is the sensor?

cheers...
SeanMc7877 is offline   Reply With Quote Quick reply to this message
 
Old 08-02-13, 07:12 PM   #4
Inactive User
 
Join Date: Aug 2011
Posts: 9
Default

I had the same issue with my 2005 plate diesel sw, light came on and it also cut out. It happened several times on a what was a journey to see our daughter 200 miles away. Long story short car went into limp mode and turned it round and came home. I took it to Peugeot, they put it on the Planet, turned out to be LOW FUEL PRESSURE, a new filter was fitted and cured the problem. The advise given to me was, if I use supermarket fuel alternate with a branded make, as supermarket fuel has more additives which can block filters prematurely.
derek8084 is offline   Reply With Quote Quick reply to this message
Old 09-02-13, 09:49 PM   #5
Inactive User
 
Join Date: Aug 2011
Location: Dorset
Posts: 677
Default De pollution system faulty P0095

On top of the engine on the manifold under the engine cover ! It's held with 1 8mm screw and 1 electrical connector


Sent from AutoGuide.com Free App
SeanMc7877 likes this.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
407 mad is offline   Reply With Quote Quick reply to this message
Old 22-02-13, 04:51 PM   #6
Inactive User
 
Join Date: Dec 2012
Location: Castlederg
Posts: 47
Default

i fitted the sensor 2day but the engine light stayed on...
I'm wondering is it a stored fault and will it take a while to go off?
Or should it have went out straight away...
SeanMc7877 is offline   Reply With Quote Quick reply to this message
Old 24-02-13, 08:13 PM   #7
Inactive User
 
Join Date: Aug 2011
Location: Dorset
Posts: 677
Default De pollution system faulty P0095

Mine started flashing and then went off on the next start up !


Sent from AutoGuide.com Free App
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
407 mad is offline   Reply With Quote Quick reply to this message
Old 25-02-13, 09:22 AM   #8
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,626
Default

It should go off after three engine cycles. If it doesn't then do another diagnostic, perhaps from someone on here with Peugeot Planet?
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 14-06-13, 04:38 PM   #9
Inactive User
 
Join Date: Dec 2012
Location: Castlederg
Posts: 47
Default

Hi , back to this thread...
My engine light never went out since..
Had it on planet today again.
Fault codes P0095 and P0098.

checked sensor, wires, connector.. everything is ok. Tryed clearing the fault but it just comes back on.
Really confused on whats bringing the light back on as ive fitted a new sensor and everything is ok.

Any ideas??

thanks for any replies...
SeanMc7877 is offline   Reply With Quote Quick reply to this message
Old 14-06-13, 05:08 PM   #10
davidireland
Guest
 
Posts: n/a
Default

P0098 is an air temp sensor fault. Reason why i know is i had it on a 307 today. New sensor fixed it nicely.

Sent from AutoGuide.com Free App
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:41 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.