car running like bag of s### - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By markjack411

Reply
 
LinkBack Thread Tools Display Modes
Old 27-11-11, 08:00 AM   #1
Senior Member
 
markjack411's Avatar
 
Join Date: Nov 2010
Location: folkestone
Posts: 128
Default car running like bag of s###

car running very badly with faults P1614 &P1644 anyone know how to remedy these,have tried wiping faults with planet but they stay.
car running in limp mode not able to accelerate past 2000 revs.
any help really appreciated.

Last edited by markjack411; 27-11-11 at 08:03 AM.
markjack411 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 27-11-11, 08:29 AM   #2
Senior Member
 
bettyswollocks's Avatar
 
Join Date: Mar 2009
Location: Northern Ireland
Posts: 9,737
Default

Quote:
Originally Posted by markjack411 View Post
car running very badly with faults P1614 &P1644 anyone know how to remedy these,have tried wiping faults with planet but they stay.
car running in limp mode not able to accelerate past 2000 revs.
any help really appreciated.
P1614 ECM Sensor Supply Malfunction
P1614 SBDS Interactive codes

P1644 Fuel pump speed control circuit malfunction

Maybe someone can help with this extra info
bettyswollocks is offline   Reply With Quote Quick reply to this message
Old 27-11-11, 09:16 AM   #3
davidireland
Guest
 
Posts: n/a
Default

Diesel, Petrol???
What engine? Bit more info!
  Reply With Quote Quick reply to this message
 
Old 27-11-11, 10:26 AM   #4
Senior Member
 
markjack411's Avatar
 
Join Date: Nov 2010
Location: folkestone
Posts: 128
Default more info

Quote:
Originally Posted by davidireland View Post
Diesel, Petrol???
What engine? Bit more info!
it is a 2.0 hdi diesel
markjack411 is offline   Reply With Quote Quick reply to this message
Old 11-12-11, 08:07 PM   #5
Senior Member
 
markjack411's Avatar
 
Join Date: Nov 2010
Location: folkestone
Posts: 128
Default fixed

all running fine now with full range of revs after removaland cleaning of dpf.
which i must admit was one of the worst jobs that i have ever carried out.
every nut, bolt and connector siezed solid.
bettyswollocks likes this.
markjack411 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:53 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.