Aairbag driving me nuts - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 24-11-16, 07:10 AM   #1
Member
 
mk23078's Avatar
 
Join Date: Dec 2014
Location: liss, hampshire
Posts: 53
Default Aairbag driving me nuts

Had the car in a garage to find and sort out a knock on the front and i have a feeling they went through the dash to check whether the rattle or knock is inside the cabin because it was so loud. I say this because the forst thing they did when i took the car there was to open the glove box and see whats making that noise. Ever since i got it back it had the airbag light on and of course "its not their fault". I took the glove box off and all wires are plugged in and checked the seat plugs too, wiggled them, jiggled them etc. Is it possible for the airbag itself to just break?! Please see error in photo. Hope someone can help with more ideas, im desperate to sort it out but im stuck. Thanks in advance
Michael
Attached Thumbnails
20161121_182802_1479974868426.jpg  
mk23078 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 24-11-16, 09:05 AM   #2
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,776
Default

Quote:
Originally Posted by mk23078 View Post
Had the car in a garage to find and sort out a knock on the front and i have a feeling they went through the dash to check whether the rattle or knock is inside the cabin because it was so loud. I say this because the forst thing they did when i took the car there was to open the glove box and see whats making that noise. Ever since i got it back it had the airbag light on and of course "its not their fault". I took the glove box off and all wires are plugged in and checked the seat plugs too, wiggled them, jiggled them etc. Is it possible for the airbag itself to just break?! Please see error in photo. Hope someone can help with more ideas, im desperate to sort it out but im stuck. Thanks in advance
Michael
thats a break in the wire going by the pic but what wire i do not know because it does not say what airbag is at fault
__________________
Great deals on car keys contact me 07599587119
trustme is offline   Reply With Quote Quick reply to this message
Old 24-11-16, 10:16 AM   #3
Member
 
mk23078's Avatar
 
Join Date: Dec 2014
Location: liss, hampshire
Posts: 53
Default

Being a level 2 igniter at fault i wouldve thought it is the one in the dash? Also if i go through diagbox into configuration of airbags they are labeled as curtain airbags, passenger seat, side airbag etc, only one being just "passenger airbag".
Hope it makes sense, i did take the glovebox off but couldnt see any broken wires. Theres only 2 short ones from either side of the airbag going to the fusebox.
mk23078 is offline   Reply With Quote Quick reply to this message
 
Old 24-11-16, 12:40 PM   #4
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,776
Default

Quote:
Originally Posted by mk23078 View Post
Being a level 2 igniter at fault i wouldve thought it is the one in the dash? Also if i go through diagbox into configuration of airbags they are labeled as curtain airbags, passenger seat, side airbag etc, only one being just "passenger airbag".
Hope it makes sense, i did take the glovebox off but couldnt see any broken wires. Theres only 2 short ones from either side of the airbag going to the fusebox.
level 2 igniter sounds like drivers airbag fault, what is the fault code?
__________________
Great deals on car keys contact me 07599587119
trustme is offline   Reply With Quote Quick reply to this message
Old 24-11-16, 01:58 PM   #5
Member
 
mk23078's Avatar
 
Join Date: Dec 2014
Location: liss, hampshire
Posts: 53
Default

Fault code is
E604-fault on passengers airbag igniter, level 2.

The picture should show.
mk23078 is offline   Reply With Quote Quick reply to this message
Old 24-11-16, 07:13 PM   #6
Member
 
mk23078's Avatar
 
Join Date: Dec 2014
Location: liss, hampshire
Posts: 53
Default

Couple more pictures from parameter measurement. Hopefully it will help
Attached Thumbnails
20161124_195006.jpg   20161124_194942.jpg   20161124_194913.jpg  
mk23078 is offline   Reply With Quote Quick reply to this message
Old 24-11-16, 08:39 PM   #7
Senior Member
 
mooi1uk's Avatar
 
Join Date: Jan 2013
Location: Cornwall UK
Posts: 1,758
Default

I don't know if the connectors under the seats are anything to do with this? Perhaps they moved the seats and a connector has come loose? Maybe worth a look.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1.6THP GTLine EAT6 Leather+Grip+ACC+O&G+Smart Boot
mooi1uk is online now   Reply With Quote Quick reply to this message
Old 24-11-16, 10:01 PM   #8
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

Have you tried to clear the fault? They might have unplugged the airbag while the battery was connected, triggering the fault.
If it does not clear, check the connectors for bent pins. Also look for corrosion.
WillNZ is offline   Reply With Quote Quick reply to this message
Old 25-11-16, 06:08 AM   #9
Member
 
mk23078's Avatar
 
Join Date: Dec 2014
Location: liss, hampshire
Posts: 53
Default

Hi guys, checked under the seat, that was the first thing and easiest.
If i clear the error it comes straight back on.
Im going to check the power at the plugs of the airbag in the dash. Does anyone know if there is continuous power to those?
mk23078 is offline   Reply With Quote Quick reply to this message
Old 25-11-16, 03:57 PM   #10
Senior Member
 
storeman's Avatar
 
Join Date: Jan 2013
Location: Oldham, UK
Posts: 5,906
Default

The picture of the diagnostic screen shows that the deactivation switch is on. This probably means that the switch is set to the 'airbag on' position but might just mean the switch is set to deactivate the passenger airbag. My owners manual says that the airbag warning light could be illuminated if the passenger airbag is deactivated. Maybe it's something that simple.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
storeman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:00 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.