407 multifunction lcd display - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 31-01-12, 09:00 AM   #1
Inactive User
 
Join Date: Jan 2012
Posts: 3
Default 407 multifunction lcd display

Hi all,

I am new at this forum, I am from Malta and I have just bought myself a peugeot 407 2.2hdi GT year 2008.

All is working great but sometimes i get in the car and the LCD screen fro the multifunction display stays off and nothing works i.e no reverse sensors no radio etc etc.......

After around 20 mins (not always the same) while driving the peugeot Logo appears and it's fine for a couple of days, then it starts all over again.

Any Ideas?


Thanks
lel181 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 31-01-12, 09:55 AM   #2
Inactive User
 
Join Date: Feb 2011
Location: PLYMOUTH,DEVON
Posts: 546
Default

whats type radio rt3,rt4,rt5 or rneg?
__________________
C4 VTR+ TU5JP4
PP OWNER PLYMOUTH:nod:
magma1974 is offline   Reply With Quote Quick reply to this message
Old 31-01-12, 10:35 AM   #3
Senior Member
 
m3mpower's Avatar
 
Join Date: Oct 2008
Location: Spain
Posts: 857
Default

Quote:
Originally Posted by lel181 View Post
Hi all,

I am new at this forum, I am from Malta and I have just bought myself a peugeot 407 2.2hdi GT year 2008.

All is working great but sometimes i get in the car and the LCD screen fro the multifunction display stays off and nothing works i.e no reverse sensors no radio etc etc.......

After around 20 mins (not always the same) while driving the peugeot Logo appears and it's fine for a couple of days, then it starts all over again.

Any Ideas?


Thanks
These symptoms are typical to the RT4 system
Possible fault: Hard Drive !
With time, it will simply fail to boot at all and stay stuck on Peugeot logo
m3mpower is offline   Reply With Quote Quick reply to this message
 
Old 31-01-12, 11:01 AM   #4
Inactive User
 
Join Date: Jan 2012
Posts: 3
Default

Many thanks for the replies guys.


Yes it is the RT4 system.

What can i do to Repair.

I happen to be an IT engineer so i could clone the hard drive and replace .

Would that work?
lel181 is offline   Reply With Quote Quick reply to this message
Old 31-01-12, 01:38 PM   #5
Senior Member
 
m3mpower's Avatar
 
Join Date: Oct 2008
Location: Spain
Posts: 857
Default

Quote:
Originally Posted by lel181 View Post
Many thanks for the replies guys.


Yes it is the RT4 system.

What can i do to Repair.

I happen to be an IT engineer so i could clone the hard drive and replace .

Would that work?
First you need to make sure it is the hard drive and not something else, i suspect it is the hard drive but that's only a probability
Then you need to find a replacement HDD as the one in RT4 is specific to Automotive, ie, resistant to very cold temperatures
And yes, cloning should work

Regards
m3mpower is offline   Reply With Quote Quick reply to this message
Old 31-01-12, 02:29 PM   #6
Inactive User
 
Join Date: Jan 2012
Posts: 3
Default

Thanks a lot mate i think it is the hard disk as sometimes the unit is really slow...... i thought it was running hot or something but a bad hard disk makes sense.



cheers will let you know
lel181 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:09 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.