407 coupe electrical failure...Please help!! - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 407
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 13-02-13, 07:39 PM   #1
Inactive User
 
Join Date: Feb 2013
Posts: 2
Exclamation 407 coupe electrical failure...Please help!!

Hi every one,
first of all i need to confess that i have done something that for a car enthusiast like me its not appropriate...

I have connected the battery wrong way around
It was very dark and i had to move my car witch was parked at the back of my property...


i have Pug 407 coupe 2.7hdi 2006 .Now my car is NOT starting and a lot of functions is not working.
central locking ,interior lights , alarm they work fine, but electric seats ,windows , the screen inside the car (stereo ,air con etc.) NOT. when i try to start the car it beeps and where it usually shows gear selection on the speedometer "N","1" etc. it shows " - " like a minus symbol.
I did checked most of the fuses but couldn't find any blown ones.
i hope its any of the relays or any hidden fuses i don't know about.
Plus i cant find my handbook so that doesn't help at all.

please help
Regards
Paul
Paul407coupe is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 13-02-13, 07:42 PM   #2
davidireland
Guest
 
Posts: n/a
Default Re: 407 coupe electrical failure...Please help!!

This could be a massively expensive mistake. The worst case is the engine ecu, bsi and engine bay fusebox are blown. Others could be blown also. Get the car to your dealer.

Sent from my GT-S5690
  Reply With Quote Quick reply to this message
Old 13-02-13, 07:52 PM   #3
Inactive User
 
Join Date: Feb 2013
Posts: 2
Default

I'm sure that might be expensive but I hope that's something not.
Is there a way to check that my self because dealerships are very expensive these days.
Paul407coupe is offline   Reply With Quote Quick reply to this message
 
Old 13-02-13, 08:45 PM   #4
davidireland
Guest
 
Posts: n/a
Default Re: 407 coupe electrical failure...Please help!!

Go to the dealer. If that came into me id be confident having that diagnosed within an hour. Cheaper than you think. Some back street garage would be messing with that for a week.

Sent from my GT-S5690
  Reply With Quote Quick reply to this message
Old 13-02-13, 09:08 PM   #5
Senior Member
 
xlineiain's Avatar
 
Join Date: May 2012
Location: NE Lincolnshire. Up the Mariners!
Posts: 1,944
Default

Oh dear. I did that to my 406 once, didnt do any harm! Some how...
Have you tried disconnecting and reconnecting following the routine? Leave it for a bit disconnected like say 20 mins? and see if it re initialises stuff?
It may have goosed something though
__________________
Not a Peugeot, but a Toyota GT86.

Last edited by xlineiain; 13-02-13 at 09:11 PM. Reason: nosey :p
xlineiain is offline   Reply With Quote Quick reply to this message
Old 14-02-13, 09:12 AM   #6
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,626
Default

I agree with David. If the electrics have been goosed you won't even get a fellow member willing to risk their Lexia3 diagnostic gear either.

Take it to Peugeot, just get a diagnostic then report back here.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:08 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.