Wiring to bypass immobiliser. - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 25-08-19, 04:56 PM   #1
Junior Member
 
Join Date: Mar 2019
Posts: 5
Default Wiring to bypass immobiliser.

1997 406 Estate, EPIC XUD 11

I caught the dreaded "Red and Green lights on keypad" disease after my son put key through the wash. Key "unrepairable".
I am going to bypass the immobiliser by powering the shutoff solenoid through a switched "Ign" source (with suitable fuse included)
On the shutoff solenoid, there are two wires: one brown, and one white. I have cut both .To which do I put "run/ign" power, and should I put the other to earth, or reconnect it to the loom?

Last edited by Simon K; 25-08-19 at 04:58 PM.
Simon K is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 26-08-19, 05:17 AM   #2
Senior Member
 
Join Date: Jul 2015
Posts: 732
Default

The wiring loom to the flip down keypad is a known weakness with these as the wires break.

Do you have the correct 4 digit code for the keypad?

The immobiliser is totally separate to the remote key in these, you can programme the RF keys to auto unlock the immobiliser BUT the immobiliser should still work in manual mode by inputting the 4 digit code if the remote key isnt working.

FWIW - I owned a 406 about 20 years back with this system, my Peugeot contact gave me a handbook supplement about programming the RF keys to auto unlock the keypad.
__________________
308 Allure 1.2 Puretech 130 hatch panoramic roof
Mr Lee is online now   Reply With Quote Quick reply to this message
Old 26-08-19, 08:25 AM   #3
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,918
Default

2 problems here the key being washed should not affect the starting as the keypad IS the immobiliser.
2 the solenoid on the pump is normally under a metal cover you cant power the wires at the plug you need to get inside the metal cover.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
 
Old 26-08-19, 10:48 AM   #4
Junior Member
 
Join Date: Mar 2019
Posts: 5
Default

Got the car second-hand with no code. Key was set up to control immobiliser. Never used the pad. When I went through owners manual I found 4 letters pencilled in. Desperate, I looked the letters up on a phone keyboard and came up with 4 numbers. Entered them in pad; result green light, then red and green and beeps.
I have removed cover on inj pump exposed the loom, taken out the ESOS and examined it, all I need to know is where to connect 12V switched input(to brown, or to white lead), and if to ground the other lead, or hook it back where it was. Only reason I have not "trial and errored" it, is because if I fed 12V into ECU where it expected ground, it would likely damage ECU.
Simon K is offline   Reply With Quote Quick reply to this message
Old 26-08-19, 11:07 AM   #5
Senior Member
 
Join Date: Jul 2015
Posts: 732
Default

I've no idea on the stop solenoid wiring, personally I'd put the
Wiring back to how it was.

If you turn the ignition ON keypad should have the red led on solid.

Enter the 4 digit code to disarm the immobiliser to get the green led on.

Then press C 0 C this should put the key pad back in to manual pin code required mode.

If you can get the remote fob working again do the same as above but press C 1 C to put the keypad back in to automatic unlock mode.
__________________
308 Allure 1.2 Puretech 130 hatch panoramic roof
Mr Lee is online now   Reply With Quote Quick reply to this message
Old 26-08-19, 04:43 PM   #6
Junior Member
 
Join Date: Mar 2019
Posts: 5
Default

Problem is, I don't have the PIN code. If I had it, Pad would give green LED, and away we go. Green and red, with beeps, is some error code from PIN Pad, I think.
Simon K is offline   Reply With Quote Quick reply to this message
Old 26-08-19, 04:52 PM   #7
Senior Member
 
Join Date: Jul 2015
Posts: 732
Default

Quote:
Originally Posted by Simon K View Post
Problem is, I don't have the PIN code. If I had it, Pad would give green LED, and away we go. Green and red, with beeps, is some error code from PIN Pad, I think.
The default factory pin code was 1 1 1 1 & most owners where to bone idle to change it to there own personal pin code.

Check the short wiring loom that plugs in to the back of the keypad as these wiring looms are known for breaking & rendering the keypad unusable.

You get THREE attempts at entering the code & then the keypad will lock you out of anymore pin code entries for 30 minutes.

If this happens you have to leave the ignition switched ON until the beeps stop & the red led stops flashing.

NOTE: Switching the ignition OFF during this lock out phase will reset the 30 minute count down when the ignition is switched back on again.

Turning the ignition OFF & then on again between pin code entries wont fool the system either, three attempts at the code then 30 minute lock out.
__________________
308 Allure 1.2 Puretech 130 hatch panoramic roof
Mr Lee is online now   Reply With Quote Quick reply to this message
Old 26-08-19, 06:31 PM   #8
Junior Member
 
Join Date: Mar 2019
Posts: 5
Default

Will check wiring, then try 1111 tomorrow. You never know, fingers crossed.
Simon K is offline   Reply With Quote Quick reply to this message
Old 27-08-19, 09:31 AM   #9
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,918
Default

If you get nowhere with that then powering the solenoid is easy it would not send 12 volts back to ecu as it would not be connected to ecu anyway on this engine its not a proper ecu anyway it just controls timing and EGR functions its still a mechanical injection pump.

Pump solenoids only need 1 12 volt feed to work if its a 2 wire solenoid i would swap it for an older 1 wire solenoid then all it needs is a power feed with ignition on you can find that at various places under bonnet.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 28-08-19, 07:25 AM   #10
Junior Member
 
Join Date: Mar 2019
Posts: 5
Default

Being a bit lazy this am, tried the "1111" reset. Result red and green. So I tried several 4 digit random codes. Results red and green. (and no "3 try lockout"???)

The pin pad could have been hiding a problem for years, as I never used it. Will look carefully at it, and if no visible, or simple connectivity faults can be found, it will be back to the solenoid.
Had to faf with lots of bits to get to solenoid, so will take a while to get it all back together. Update in several days hopefully.

BTW thanks for all the info from members, it is giving me the incentive to keep at it!

As I was putting it back together, I found a "spare" 3-pin connector. Wires come from the loom at top of driver-side suspension tower. After some head-scratching, and poring over circuit diagrams, it would seem that some models have an inertia switch, although this one didn't! Hope that's the end of the mystery connector!

Last edited by Simon K; 28-08-19 at 05:16 PM.
Simon K is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:41 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.